Autor Tema: Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX  (Leído 10120 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado zann

  • Newbie
  • *
  • Mensajes: 16
    • Ver Perfil
Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« en: 09 de Octubre del 2015, 18:53:39 pm »
Hola. ¿Seríais tan amables de recuperar los manuales de Jantoni? Es una lástima que tanto esfuerzo se haya perdido :'(
Además todo estaba muy bien explicado.

Gracias

jantoni

  • Visitante
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #1 en: 09 de Octubre del 2015, 19:04:21 pm »
Bueno....intentaremos recuperarlos y pasarlos íntegros a la wiki o aquí mismo.

Estamos pendientes de poder disponer de parte de la información del antiguo foro, aunque no será para acceso general, pero seguro que podremos recuperar todo o casi todo.

No obstante, mientras se recupera, o mientras edite un nuevo manual, dime que te ocurre y te ayudamos.

Saludos.

Desconectado zann

  • Newbie
  • *
  • Mensajes: 16
    • Ver Perfil
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #2 en: 10 de Octubre del 2015, 12:22:25 pm »
Tengo funcionando WeeWX en la Raspberry Pi sin problemas con la PCE. Justo cuando iba comenzar la instalación de la plantilla de Meteoclimatic para poder enviar los datos se fue al garate el foro y ahí me quedé. Necesitaría los pasos de instalación de la plantilla en la Raspberry para poner en marcha los datos en Meteoclimatic.

Muchas gracias y saludos

jantoni

  • Visitante
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #3 en: 10 de Octubre del 2015, 13:25:22 pm »
En la wiki tienes el procedimiento. Y antes también estaba.

http://wiki.meteoclimatic.net/wiki/WeeWX

Desconectado zann

  • Newbie
  • *
  • Mensajes: 16
    • Ver Perfil
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #4 en: 10 de Octubre del 2015, 19:58:35 pm »
Si, estuve mirando ahí pero no me quedaba claro el procedimiento. Me gustaría emplear el Linux-PHP Meteoclimatic, a ser posible con la Raspberry, pero en enlace que aparece en http://wiki.meteoclimatic.net/wiki/Linux-PHP_Meteoclimatic para su descarga no funciona.

Por otro lado, cómo puedo meter la plantilla en la Raspberry? El programa que entra por ssh me dejaba ver el contenido de la Raspberry y copiar archivos de ella a mi ordenador, pero no al revés... Es como que la Raspy se protege contra escritura.

Saludos,

« Última modificación: 11 de Octubre del 2015, 12:02:36 pm por zann »

jantoni

  • Visitante
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #5 en: 11 de Octubre del 2015, 13:29:17 pm »
En el foro de software de Meteoclimatic tienes los ficheros que he subido esta mañana.

La wiki la actualizaré en un momento.

Saludos.

Desconectado zann

  • Newbie
  • *
  • Mensajes: 16
    • Ver Perfil
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #6 en: 13 de Octubre del 2015, 20:34:21 pm »
Hola de nuevo, algunos problemas detectados en el proceso de instalación:

En la dirección web que he elegido para el redireccionamiento (meteopuenteromano.no-ip.org) si no pongo /weewx no me sale la página de inicio. He copiado el archivo html de la carpeta weewx y lo he pegado fuera, pero sólo queda texto limpio ¿Qué hay que hacer para que la web salga sin necesidad de poner / y la carpeta ruta al index.html?

Por otro lado llevo un tiempo observando que sólo me marca la presión relativa, pese a que en la consola de la estación marca la presión absoluta. ¿A qué puede ser debido esto?  :-[

Gracias y saludos


jantoni

  • Visitante
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #7 en: 13 de Octubre del 2015, 21:58:37 pm »
La presión absoluta vale de poco.

Siempre utilizamos la presión relativa, aunque en Weewx salen las 3, barómetro, absoluta y altímetro.

El tema de la web es normal, aunque es un tema que no corresponde a este foro, sino a foros dedicados a Apache2.

Dado que Apache2 es complicado, te diré que si escribes un fichero /var/www/index.php te redirigirá a donde digas:

Por ejemplo el mio:

Código: [Seleccionar]
root@mele1:/var/www# cat index.php
<META HTTP-EQUIV="refresh" CONTENT="1; url=weewx2/index.html">

Desconectado zann

  • Newbie
  • *
  • Mensajes: 16
    • Ver Perfil
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #8 en: 14 de Octubre del 2015, 09:04:26 am »
Muchísimas gracias Jantoni, todo OK  ;)

Desconectado zann

  • Newbie
  • *
  • Mensajes: 16
    • Ver Perfil
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #9 en: 15 de Octubre del 2015, 19:43:13 pm »
Hola, tengo una duda, en la web generada por Weewx al traducir a mano todo al castellano y ponerla en marcha de nuevo en mi navegador (Mozilla)  salen errores en todas las letras que llevan tilde. Por lo que estoy viendo esto depende del navegador con el que entro, porque si entro desde el móvil no hay problema, pero ¿hay alguna forma de corregir eso?

Saludos

jantoni

  • Visitante
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #10 en: 15 de Octubre del 2015, 20:21:35 pm »
Si, el galimatías del juego de caracteres.

Personalmente uso el sistema antiguo, usando los acutes

á = &aacute;
é = &eacute;
ñ = &ntilde;

Cañón = Ca&ntilde;&oacute;n

Es un Co&ntilde;azo pero funciona con todos los navegadores.

Y te olvidas de la codificación de los caracteres, que te darán problemas en la generación de los gráficos y páginas con weewx, y cuando lo corriges, entonces te da problemas con el interface de la raspi, y cuando lo corriges........

100% eficaz garantizada.....y al cabo de 10 minutos ya lo escribes hasta deprisa :D :D :D :D :D

Desconectado zann

  • Newbie
  • *
  • Mensajes: 16
    • Ver Perfil
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #11 en: 14 de Noviembre del 2015, 12:33:48 pm »
Hola, esta mañana de repente la estación ha dejado de emitir datos. Si entro a syslog me sale lo siguente:


pi@raspberrypi ~ $ sudo tail -f /var/log/syslog
Nov 14 12:19:06 raspberrypi kernel: [   38.340621] uart-pl011 3f201000.uart: no DMA platform data
Nov 14 12:19:07 raspberrypi avahi-daemon[2420]: Server startup complete. Host name is raspberrypi.local. Local service cookie is 1478184763.
Nov 14 12:19:08 raspberrypi avahi-daemon[2420]: Service "raspberrypi" (/services/udisks.service) successfully established.
Nov 14 12:19:08 raspberrypi kernel: [   39.713005] cfg80211: Calling CRDA to update world regulatory domain
Nov 14 12:19:33 raspberrypi kernel: [   42.873077] cfg80211: Calling CRDA to update world regulatory domain
Nov 14 12:19:36 raspberrypi kernel: [   46.033054] cfg80211: Calling CRDA to update world regulatory domain
Nov 14 12:19:39 raspberrypi kernel: [   49.193098] cfg80211: Calling CRDA to update world regulatory domain
Nov 14 12:19:42 raspberrypi kernel: [   52.353105] cfg80211: Calling CRDA to update world regulatory domain
Nov 14 12:19:45 raspberrypi kernel: [   55.513111] cfg80211: Calling CRDA to update world regulatory domain
Nov 14 12:19:48 raspberrypi kernel: [   58.673093] cfg80211: Exceeded CRDA call max attempts. Not calling CRDA

¿A qué puede deberse?

Gracias

jantoni

  • Visitante
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #12 en: 14 de Noviembre del 2015, 13:11:31 pm »
Tienes que mirar los mensajes de weewx, los mensajes que pones son del sistema operativo.

Saludos.

Desconectado zann

  • Newbie
  • *
  • Mensajes: 16
    • Ver Perfil
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #13 en: 14 de Noviembre del 2015, 19:27:06 pm »
Qué código hay que meter?  ::)

jantoni

  • Visitante
Re:Puesta en marcha PCE-FWS 20 con Raspberry Pi y WeeWX
« Respuesta #14 en: 14 de Noviembre del 2015, 20:30:16 pm »
Pues si es una de mis imagenes:

tail -n 100 -f /var/log/weewx.log

Si es otra instalación pues no te puedo ayudar, estará mezclado con uno de los múltiples ficheros de log de Debian