Mostrar Mensajes

Esta sección te permite ver todos los posts escritos por este usuario. Ten en cuenta que sólo puedes ver los posts escritos en zonas a las que tienes acceso en este momento.


Mensajes - jmviper

Páginas: [1] 2 3 ... 136
1
WeeWX / Re:Failed to start LSB: weewx weather system.
« en: Hoy a las 15:16:09 »
El fallo es del archivo extensions.py ?? Lo tocaste anteriormente ? Fecha de la raspy del 14 de febrero ?? No entiendo

2
WeeWX / Re:Failed to start LSB: weewx weather system.
« en: Hoy a las 15:04:54 »
Tienes fecha del 14 de febrero en tu raspi, por eso te da el error weewx.

Mira a ver que te pone ejecutar timedatectl status. Seguramente sea cosa de la actualización del NTP

3
Weather Display / Re:Problema medición UV
« en: Hoy a las 15:01:11 »
Si quieres puedes hacer una copia del archivo wdisplay.ini de WD (cierra WD antes de hacerla) y la pones en un zip adjunto para ver dónde está el fallo con mi Davis.

4
La línea que pusiste anteriormente no parece ser de un log de servidor FTP sino de un servidor WEB (posiblemente apache) con el acceso por parte de un navegador a la plantilla. Esos accesos se pueden dar en cualquier momento (quizás es uno mío).

Tendrás que ver el log de FTP de MX que es el cliente de porqué no sube la plantilla.

En MX vas a Settings -> Internet Settings y expandes Web FTP/Settings y si no tienes marcada la casilla FTP logging márcala. Si la tienes marcada entonces ya te estará creando el log en la carpeta donde tengas MX (creo que es el archivo ftplog.txt o algo así). Le das a Save abajo del todo para guardar la configuración.

Ahí podrás ver qué te dice MX al intentar subir la plantilla.

Decir que no se debe de dejar el log siempre activado y mucho menos si se están subiendo archivos con el realtime… se pueden generar logs muy muy grandes de gigas de tamaño. Solamente se debe de activar para ver si hay algún problema como en este caso. Lo normal es dejarlo por lo menos un día y luego analizarlo.

5
Eso es solo una línea del log, habría que verlas una a una cada cinco minutos. Tienes la raspi con wifi ? Tiene problemas de conexión ?
Lo normal sería eso, que tuviese cortes de wifi y no pudiese subir la plantilla.


6
Weather Display / Re:Problema medición UV
« en: Hoy a las 11:39:38 »
Hola

Mira a ver en Control Panel -> Compensaciones lluvia inicial y pestaña Davis VP UV/ET si tienes algo puesto en Desvío de Davis VP UV (ajuste en %), si es así ponlo a 0.

Saludos

7
En qué intervalo tienes MX que te genere/suba la plantilla ? lo ideal serían 5 minutos. El problema no sé si se solucionaría con el realtime... el problema está, como ya dije anteriormente, en qué ocurre cuando no sube MX la plantilla. Estará en el log si lo tienes habilitado de FTP en MX. Con eso ya podría verte el problema el encargado del servidor a donde envías la plantilla.

8
WeeWX-Skins / Re:Datos gráficas
« en: Ayer a las 22:40:36 »


¿podrias indicar cómo has implementado charts.js o cómo consigues (si lo conoces) que highcharts 'lea' un archivo *.json?



En el enlace que te puse anteriormente de GitHub de weewx-highcharts hay unos archivos en la carpeta web server: scripts (con plots.js y theme.js y los archivos graphs.html y wxgraphs2.php. El segundo es para implementarlo en las plantillas de Saratoga con php y el primero es el que debes de poner junto con la carpeta scripts en la raspi en los archivos web de weewx (puede que en /var/www/html/weewx hay instalaciones diferentes pero es la carpeta weewx).
En el archivo graphs.html mira que las etiquetas <script> que apuntan a las rutas locales de los dos archivos JS de la carpeta scripts apunten a ellos correctamente, ponen por ejemplo src="../scripts/js/theme.js" y deberían de poner src="scripts/js/theme.js"

Quedaría implementarlo en el index.html.tmpl (si lo quieres ahí) de Neowx

Te adjunto pantallazos


9
Esta es la última plantilla que hay en la URL de tu plantilla:

*VER=DATA2 *COD=ESPVA1200000012450A *SIG= *UPD=26/06/2019 03:15 *TMP=16.9 *WND=1.6 *AZI=WNW *BAR=1016.76 *HUM=95 *SUN=0 *UVI=0.0 *DHTM=20.1 *DLTM=16.7 *DHHM=95 *DLHM=91 *DHBR=1018.15 *DLBR=1016.76 *DGST=6.4 *DSUN= *DHUV= *DPCP=0.0 *WRUN=2.8 *MHTM=30.7 *MLTM=3.1 *MHHM=97 *MLHM=10 *MHBR=1023.98 *MLBR=1005.42 *MGST=80.5 *MSUN= *MHUV= *MPCP=1.4 *YHTM=31.1 *YLTM=-7.2 *YHHM=98 *YLHM=10 *YHBR=1037.32 *YLBR=990.55 *YGST=83.7 *YSUN= *YHUV= *YPCP=213.8 *EOT*

He borrado el sig y como ves sigue todavía en las 03:15. Mira a ver porqué no se actualiza. Puede que Cumulus MX no esté subiendo bien la plantilla por FTP y falle la mayoría de veces.

10
La plantilla parece estar desactualizada las veces que estoy viéndola. La última plantilla ahora mismo es de hoy a las 03:15.

Mira a ver si tienes algún problema de subida de la plantilla a ese servidor. Hay que ir descartando cosas antes de decírselo al webmaster.

11
Hola Fran

Prueba a poner la dirección URL de la plantilla empezando con https:// en vez de http:// en la ficha de tu estación en meteoclimatic.

12
WeeWX-Skins / Re:Datos gráficas
« en: 25 de Junio del 2019, 11:45:14 am »

o si incluso conocéis algún skin más además de este de belchertown que tenga este tipo de salida gráfica.


Si quieres implementar highcharts con weewx:

https://github.com/gjr80/weewx-highcharts

Si te hace falta ayuda abre un nuevo hilo en este mismo foro de weewx

13
WeeWX-Skins / Re:Datos gráficas
« en: 24 de Junio del 2019, 20:56:49 pm »
Hola

Pues supongo que los normales.... temperatura y humedad, velocidad del viento y dirección, presión, lluvia del día... tenías pensado algo en especial ?

14
Cumulus y Cumulus MX / Re:migracion de cumulus a cumulus MX
« en: 22 de Junio del 2019, 20:39:29 pm »
No sé cómo lo tienes... no sé cierto si MX pone punto o coma según el decimal establecido en la configuración regional de Windows. Si has tenido Cumulus en el anterior pc con coma decimal lo normal es que ahora esté creando los logs MX con coma.

Otra cosa según veo es de dónde saca los récords que son los archivos today.ini (hoy), month.ini (mes) y year.ini (año). Hay otros más pero éstos son de donde se sacan los valores para meteoclimatic (cosa aparte es el acumulado de lluvia que es la suma de cada día del mes o año actuales del dayfile.txt) y en el mío llevan punto decimal (los programas o aplicaciones internamente operan con punto decimal en los cálculos).

Mira a ver esos archivos qué valores tienen erróneos y ve corrigiéndolos con los verdaderos en esos archivos en data. Supongo que lo podrás ir haciendo con esos mismos archivos de Cumulus 1 que son los que tenías. Cierra MX antes de editar esos archivos y haz copia de seguridad por si sale algo mal.

15
Cumulus y Cumulus MX / Re:migracion de cumulus a cumulus MX
« en: 22 de Junio del 2019, 14:37:05 pm »
No sé si tendrá que ver con cambio de puntos por comas decimales de cómo lo tenías antes a como lo tienes ahora.

Supongo que le habrás copiado el contenido de la carpeta data de Cumulus a Cumulus MX. Creo que yo en su día tuve algún problema así al pasar de uno a otro. Y Cumulus MX creo que no tiene el editor que tiene Cumulus con los récords....

Por cierto....parece estar traducido...lo has traducido tú o es de algún sitio?

Páginas: [1] 2 3 ... 136