Mostrar Mensajes

Esta sección te permite ver todos los posts escritos por este usuario. Ten en cuenta que sólo puedes ver los posts escritos en zonas a las que tienes acceso en este momento.


Mensajes - GarciaMiguel

Páginas: 1 [2] 3
16
WeeWX / Re:Cambiar estación Weewx
« en: 26 de Diciembre del 2017, 11:02:09 am »

No sé si es por la versión de weewx que tengo. ¿Quizàs el comando sería clear sin el memory?


Pues eso parece.... es la opción que te dice en la ayuda en esa versión, sudo wee_device --clear

Muchas gracias de nuevo. Lo he ejecutado y parece que ha realizado el proceso.

Aunque en la generación de la plantilla me siguen saliendo datos antiguos, no lo entiendo, se trata de datos en que la presión se salía de rango por el viaje y la diferencia de altura entre las dos ubicaciones, y obviamente meteoclimatic me indica barómetro fuera de rango para datos mensuales y anuales. Todo ésto pasa habiendo borrado el datalogger y eliminado el archivo, por lo que no entiendo de dónde saca los datos. Voy a buscar por el foro solución a éste nuevo entretuerto.

Muchas gracias de nuevo.

17
WeeWX / Re:Cambiar estación Weewx
« en: 26 de Diciembre del 2017, 01:17:34 am »
Muchas gracias por vuestras respuestas, jmviper y jantoni.

He realizado lo que me comentáis per el comando sudo wee_device --clear-memory me indica lo siguiente:

pi@raspberrypi:~ $ sudo wee_device --clear-memory
Using configuration file /etc/weewx/weewx.conf
Using Vantage driver version 3.0.7 (weewx.drivers.vantage)
Usage: wee_device [config_file] [--help] [--info] [--clear]
    [--set-interval=SECONDS] [--set-altitude=FEET] [--set-barometer=inHg]
    [--set-bucket=CODE] [--set-rain-year-start=MM]
    [--set-offset=VARIABLE,OFFSET]
    [--set-transmitter-type=CHANNEL,TYPE,TEMP,HUM]
    [--set-time] [--set-dst=[AUTO|ON|OFF]]
    [--set-tz-code=TZCODE] [--set-tz-offset=HHMM]
    [--set-lamp=[ON|OFF]] [--dump] [--logger_summary=FILE]
    [--start | --stop]

wee_device: error: no such option: --clear-memory
pi@raspberrypi:~ $


No sé si es por la versión de weewx que tengo. ¿Quizàs el comando sería clear sin el memory?

Gracias por adelantado.

18
WeeWX / Re:Cambiar estación Weewx
« en: 22 de Diciembre del 2017, 20:12:42 pm »
Buenas tardes,

Aprovecho éste hilo para preguntar una cuestion parecida, en mi caso no cambio la estación, sino lo que cambio es la ubicación de la estación, supongo que también tengo borrar la base de datos /var/lib/weewx/weewx.sdb, supongo que weewx ya creará una nueva, y cambiar la ubcación en la consola y en weewx.conf.

¿El datalogger (se trata de una Davis Vantage Pro2 wireless) cómo se borra? Lo digo para no contaminar los datos de la nueva ubicación.

Gracias de antemano.

19
WeeWX / Re:Instalación de Weewx automatizada
« en: 22 de Diciembre del 2017, 20:05:51 pm »
Hola Jose Antonio,

Lo acabo de probar y en el punto 4 me sale esto:

pi@raspberrypi:~ $ sudo ./weewx.sh
./weewx.sh: 2: ./weewx.sh: Syntax error: newline unexpected

Hola a todos, a mi me sale ese error todo el rato y no se a qué puede deberse:

pi@raspberrypi:~ $ sudo ./weewx.sh
./weewx.sh: 2: ./weewx.sh: Syntax error: newline unexpected

 :;

A mi me pasa lo mismo, y estoy encallado, ¿cómo lo has podido solucionar?

Gracias.

20
WebCam / Re:Camara IP China y Raspberry Pi
« en: 14 de Diciembre del 2017, 23:42:21 pm »
Buenas noches,

Gracias por la información, fantástico hilo.

Una pregunta: ¿el script funcionaría con una webcam USB no IP? yo entiendo que no, pero en ese caso para que el script funcionase ¿qué cambios se debería hacer? El motivo es que quiero reciclar una Lifecam que tengo para subir las imágenes a meteoclimatic, y quizás también como cámara de seguridad con detector de movimiento.

Estoy un poco pez en linux y me cuesta bastante adaptarme aunque ya tengo el weewx funcionando con la raspberry.

Gracias de antemano.

Un saludo,

21
Hola,

Ya está funcionando!! Muchas gracias, no había recargado después de modificar weewx.conf, modificando skin.conf no me hace caso, cosa que no entiendo.

Gracias y un saludo.

Postdata: aunque no envía decimales. Sólo números enteros. Trabajo para mañana ya... :( (SOLUCIONADO: modificando el scrpt meteoclimatic.sh indicando meteoclimatic_http.php en lugar de meteoclimatic_http.php.old)

22
Hola.

Gracias jantoni. He hecho lo que me has dicho pero no hace caso sigue saliendo la plantilla y el index.html igual y de hecho en skin.conf me aparecen las unidades en US:

[[Groups]]
        # For each group of measurements, this section sets what units to
        # use for it.
        # NB: The unit is always in the singular. I.e., 'mile_per_hour',
        # NOT 'miles_per_hour'

        group_altitude     = foot                 # Options are 'foot' or 'meter'
        group_degree_day   = degree_F_day         # Options are 'degree_F_day' or 'degree_C_day'
        group_direction    = degree_compass
        group_moisture     = centibar
        group_percent      = percent
        group_pressure     = inHg                 # Options are 'inHg', 'mmHg', 'mbar', or 'hPa'
        group_radiation    = watt_per_meter_squared
        group_rain         = inch                 # Options are 'inch', 'cm', or 'mm'
        group_rainrate     = inch_per_hour        # Options are 'inch_per_hour', 'cm_per_hour', or 'mm_per_hour'
        group_speed        = km_per_hour        # Options are 'mile_per_hour', 'km_per_hour', 'knot', or 'meter_per_second'
        group_speed2       = km_per_hour2       # Options are 'mile_per_hour2', 'km_per_hour2', 'knot2', or 'meter_per_second2'
        group_temperature  = degree_F             # Options are 'degree_F' or 'degree_C'


Es como si no hiciera caso de skin.conf.

Entonces he deshecho éste cambio y he ido a modificar el archivo weewx.conf, en el apartado StdReport, y allí las unidades son exactamente las que me salen en las plantillas (meteoclimatic.htm e index.html) pero si modifico aquí meter_per_hour por km_per_hour entonces no me genera las citadas plantillas (meteoclimatic.htm e index.html), hay algo que le provoca confusión:

[StdReport]

    # Where the skins reside, relative to WEEWX_ROOT
    SKIN_ROOT = /etc/weewx/skins

    # Where the generated reports should go, relative to WEEWX_ROOT
    HTML_ROOT = /var/www/weewx

    # The database binding indicates which data should be used in reports.
    data_binding = wx_binding

    # Each of the following subsections defines a report that will be run.

    [[StandardReport]]
        # See the customizing guide to change the units, plot types and line
        # colors, modify the fonts, display additional sensor data, and other
        # customizations. Many of those changes can be made here by overriding
        # parameters, or by modifying templates within the skin itself.

        # The StandardReport uses the 'Standard' skin, which contains the
        # images, templates and plots for the report.
        skin = Standard
        [[[Units]]]
            [[[[Groups]]]]
                group_altitude = meter
                group_speed2 = meter_per_second2
                group_pressure = mbar
                group_rain = mm
                group_rainrate = mm_per_hour
                group_temperature = degree_C
                group_degree_day = degree_C_day
                group_speed = meter_per_second


Por tanto, si lo modifico en skin.conf no me hace caso, y si lo modifico en weewx.conf no me genera las plantillas.

Sigo investigando...

23
¡Muchas gracias! Ya lo tengo enviando datos a Meteoclimatic desde ayer por la tarde y funciona correctamente, sin errores. Lo que al guardar meteoclimatic.sh en home/pi/meteoclimatic/ cambié la dirección dentro del script, ya que sino lo buscaba en root/.

Gracias.

Un saludo.

Me acabo de dar cuenta que en la plantilla se está rellenando con los datos de viento en m/s  :-X. En el Weewx lo tengo en:

target_unit = US

La http://IP/weewx/week.html también me lo genera en m/s.

¿Debo introducir algun parámetro más en la plantilla para realizar la conversión?

Un saludo.

24
¡Muchas gracias! Ya lo tengo enviando datos a Meteoclimatic desde ayer por la tarde y funciona correctamente, sin errores. Lo que al guardar meteoclimatic.sh en home/pi/meteoclimatic/ cambié la dirección dentro del script, ya que sino lo buscaba en root/.

Gracias.

Un saludo.

25
Hola,

No sé, sólo se me ocurre que hay que copiar lo que aparece en la imagen sustituyendo lo que hay en la plantilla original... Pero en la wiki pone que sólo hay que modificar el COD y el SIG.

Probaré eso.

26
Hola de nuevo,

Algo he hecho mal, weewx no me sustituye los valores de la estación en la plantilla, es decir genera el meteoclimatic.htm a partir de meteoclimatic.htm.tmpl pero me aparecen los mismos códigos, no me sustituye el código *TMP=%temp% por el valor de la temperatura, y así con todos.

He revisado el skin.conf y está tal y como indica la wiki.

Gracias de antemano.

Un saludo.

27
Hola,

Gracias a los dos. Tenéis razón, está todo muy bien explicado en la wiki, no se porque me he quedado encallado en la página de Linux-PHP y no había encontrado la de WeeWX y Meteoclimatic, he seguido los pasos y ahora estoy esperando a que empiece a enviar datos a meteoclimatic.

Gracias.

Un saludo.

28
Hola,

Ok, muchas gracias.

Ya he guardado los archivos de linux-PHP Meteoclimatic en /home/pi/meteoclimatic/ ahora cuando hago:

pi@raspberrypi:~ $ sudo php /home/pi/meteoclimatic/meteoclimatic_http.php
/var/www/weewx/meteoclimatic.htm?
pi@raspberrypi:~ $


He ido a buscar si en /var/www/weewx/ estaba el archivo meteoclimatic.htm, y efectivamente no estaba. Entiendo pues que ahora la plantilla que me he descargado la tengo que guardar en /var/www/weewx/ con el nombre meteoclimatic.htm, ¿correcto?

¿Y como weewx actualiza la plantilla meteoclimatic.htm?

Gracias.

Un saludo.

29
Muchas gracias.
Ya lo he cambiado y parece que va bien.

Hola,

Para descargar la plantilla de meteoclimatic y utilizar WeeWX como programa de adquisición de datos, ¿Qué software marcaste en la ficha de tu estación? ¿FreeWX?

Yo le marco ésta opción, pero cuando hago clic sobre "Descargar plantilla" se me abre una pagina en blanco, y no se descarga nada.

Un saludo.

30
WeeWX / Re:Instalación de Weewx automatizada
« en: 08 de Abril del 2016, 19:04:17 pm »
Ummmmm..... Te contesto desde el móvil, por lo que no me puedo extender mucho.

Ese adaptador serial USB parece no funcionar correctamente, dados los mensajes de error.

A ver si mañana me puedo expresar un poco mejor.

Saludos

Buenas tardes,
Al final, he comprado otro adaptador serial-USB y ya no me indica el error, pero me sigue sin generar la página. Si miro las conexiones USB es el ttyUSB0, por lo que está bien definido, no sé ver el datalogger:

pi@raspberrypi:~ $ dmesg | grep tty*
[    0.000000] Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2709.boardrev=0xa21041 bcm2709.serial=0x35b3c015 smsc95xx.macaddr=B8:27:EB:B3:C0:15 bcm2708_fb.fbswap=1 bcm2709.uart_clock=3000000 bcm2709.disk_led_gpio=47 bcm2709.disk_led_active_low=0 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000  dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
[    0.001525] console [tty1] enabled
[    0.053164] Setting up static identity map for 0x8240 - 0x8274
[    0.097669] 3f201000.uart: ttyAMA0 at MMIO 0x3f201000 (irq = 83, base_baud = 0) is a PL011 rev2
[    0.598437] console [ttyAMA0] enabled
[    0.729024] raspberrypi-firmware soc:firmware: Attached to firmware from 2016-03-15 14:47
[    1.341442] Setting default values for core params
[    1.347770] Finished setting default values for core params
[    3.405166] systemd[1]: Expecting device dev-ttyAMA0.device...
[    3.684974] systemd[1]: Starting system-getty.slice.
[    3.694348] systemd[1]: Created slice system-getty.slice.
[    3.701666] systemd[1]: Starting system-serial\x2dgetty.slice.
[    3.711724] systemd[1]: Created slice system-serial\x2dgetty.slice.
[    5.439521] usb 1-1.5: pl2303 converter now attached to ttyUSB0
pi@raspberrypi:~ $ ps aux | grep wee
root       627  3.2  3.2  46332 31264 ?        S    16:04   5:35 python /usr/bin/weewxd --daemon --pidfile=/var/run/weewx.pid /etc/weewx/weewx.conf
pi        1363  0.0  0.2   4276  1908 pts/0    S+   18:56   0:00 grep --color=auto wee
pi@raspberrypi:~ $


No sé si tiene que ver, pero yo estoy conectado por wifi (un adaptador wifi-USB), no por LAN.

También he comprobado si funciona el weewx, y parece que sí. ¿todo el mundo que instala weewx por primera vez no tiene problemas? Es que creo que soy el único que pregunta, y sinceramente me encuentro perdido.

Por eso reitero las gracias por el apoyo.

Un saludo.

Miguel.

Páginas: 1 [2] 3