Mostrar Mensajes

Esta sección te permite ver todos los posts escritos por este usuario. Ten en cuenta que sólo puedes ver los posts escritos en zonas a las que tienes acceso en este momento.


Mensajes - GarciaMiguel

Páginas: 1 2 [3]
31
WeeWX / Re:Instalación de Weewx automatizada
« en: 01 de Abril del 2016, 21:33:30 pm »
Buenas tardes.

De nuevo por aquí, resulta que cuando instalé la imagen y lo configuré en modo simulador, y tras todo el proceso automático me preparaba las páginas. Pero ahora que lo he conectado a la Davis con serial datalogger mediante un conversor a USB no las realiza. He desinstalado e instalado todo 2 veces y no hay manera de que me funcione, no sé qué puede fallar.

Pensaba quizás que el USB no fuera el 0 o que falle el conversor USB, pero creo que funciona bien:


pi@raspberrypi:~ $ dmesg | grep tty*
[    0.000000] Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2709.boardrev=0xa21041 bcm2709.serial=0x35b3c015 smsc95xx.macaddr=B8:27:EB:B3:C0:15 bcm2708_fb.fbswap=1 bcm2709.uart_clock=3000000 bcm2709.disk_led_gpio=47 bcm2709.disk_led_active_low=0 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000  dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
[    0.001485] console [tty1] enabled
[    0.053124] Setting up static identity map for 0x8240 - 0x8274
[    0.097226] 3f201000.uart: ttyAMA0 at MMIO 0x3f201000 (irq = 83, base_baud = 0) is a PL011 rev2
[    0.597992] console [ttyAMA0] enabled
[    0.728921] raspberrypi-firmware soc:firmware: Attached to firmware from 2016-03-04 17:53
[    1.340985] Setting default values for core params
[    1.347307] Finished setting default values for core params
[    3.506593] systemd[1]: Expecting device dev-ttyAMA0.device...
[    3.787808] systemd[1]: Starting system-getty.slice.
[    3.797653] systemd[1]: Created slice system-getty.slice.
[    3.805193] systemd[1]: Starting system-serial\x2dgetty.slice.
[    3.815531] systemd[1]: Created slice system-serial\x2dgetty.slice.
[    5.663309] usb 1-1.5: pl2303 converter now attached to ttyUSB0
[   18.106705] pl2303 ttyUSB0: pl2303_get_line_request - failed: -32
[   18.108076] pl2303 ttyUSB0: pl2303_get_line_request - failed: -32
[   40.255427] pl2303 ttyUSB0: error sending break = -32
[ 6161.710885] pl2303 ttyUSB0: pl2303_get_line_request - failed: -32
[ 6177.856436] pl2303 ttyUSB0: error sending break = -32



Y compruebo si funciona:


pi@raspberrypi:~ $ ps aux | grep wee
pi       18490  0.0  0.1   4276  1848 pts/0    S+   21:21   0:00 grep --color=auto wee



Tengo la estación davis vantage pro 2 conectada por USB y la rapberry conectada con un adaptador USB wifi:


[    2.924532] usb 1-1.4: new high-speed USB device number 4 using dwc_otg
[    3.046107] usb 1-1.4: New USB device found, idVendor=0bda, idProduct=8176
[    3.054941] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    3.064165] usb 1-1.4: Product: 802.11n WLAN Adapter
[    3.071026] usb 1-1.4: Manufacturer: Realtek
[    3.077101] usb 1-1.4: SerialNumber: 00e04c000001
[    3.164506] usb 1-1.5: new full-speed USB device number 5 using dwc_otg
[    3.286748] usb 1-1.5: New USB device found, idVendor=067b, idProduct=2303
[    3.295445] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.304476] usb 1-1.5: Product: USB 2.0 To COM Device
[    3.311218] usb 1-1.5: Manufacturer: Prolific Technology Inc.
[    5.663309] usb 1-1.5: pl2303 converter now attached to ttyUSB0




No sé si alguien me puede ayudar.

No tengo nada claro, no sé que falla, hay algo que interpreto mal. Y empiezo a desesperar...

Gracias de antemano.

Un saludo.

32
WeeWX / Re:Instalación de Weewx automatizada
« en: 10 de Marzo del 2016, 20:18:17 pm »
Buenas tardes,

Yo metí el raspbian en la SD y fui siguiendo los pasos que aparecen en el manual para instalar el weewx y no me funcionó, por lo que opté a desinstalar el weewx y cargar script.

He cargado tu script en una Raspberry Pi 2 y ha funcionado a la primera, ya me genera la página (aunque en modo simulador, aún no me ha llegado el adaptador serial-USB).

Ahora he modificado /etc/fstab para que me grabe el log en la RAM:


pi@raspberrypi:~ $ cat /etc/fstab
proc            /proc           proc    defaults          0       0
/dev/mmcblk0p1  /boot           vfat    defaults          0       2
/dev/mmcblk0p2  /               ext4    defaults,noatime  0       1
# a swapfile is not a swap partition, no line here
#   use  dphys-swapfile swap[on|off]  for that
tmpfs /var/log tmpfs nodev,nosuid,size=20M 0 0


Lo que he visto que el notime ya estaba activado, es decir que lo de Inhabilitar el registro de lectura de los ficheros ya esto hecho también, ¿no?

Entiendo que para la modificación del intervalo de generación de weewx necesito estar conectado a la DAVIS, ¿no?

Gracias.

33
WeeWX / Re:Nuevo tutorial de instalación de Weewx
« en: 05 de Marzo del 2016, 12:22:57 pm »
Ese mensaje de error hace referencia a pasos previos que no has completado.

Cuando intentas instalar Weewx con

sudo dpkg -i weewx*.deb

Te saldrá ese mensaje indicando que faltan paquetes de software.

Lo solucionas con:

sudo apt-get -f install

Y luego continuas.

En cuanto a si la versión 3.40 no tiene el falso reloj, es una pregunta erronea. El falso reloj o fakehwclock es un paquete del sistema operativa y no de Weewx

Por tanto, el falso reloj puede venir instalado con Jessie....o no.

Ok. Mil gracias Jantoni!!!  ;)

34
WeeWX / Re:Nuevo tutorial de instalación de Weewx
« en: 05 de Marzo del 2016, 09:33:03 am »
Buenos días.
Al final me he decidido a dar el paso del viejo pc a la raspberry pi 2, a pesar de mis mínimos conocimientos de linux.
Estoy instalando el weewx que ahora ya está la versión 3.4, ¿puede ser que ésta versión no tenga el falso reloj?


pi@raspberrypi:~ $ sudo apt-get remove fake-hwclock
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 weewx : Depends: python-configobj (>= 4.5) but it is not going to be installed
         Depends: python-cheetah (>= 2.0) but it is not going to be installed
         Depends: python-imaging (>= 1.1.6) but it is not going to be installed
         Depends: python-usb (>= 0.4) but it is not going to be installed
         Recommends: python-dev (>= 2.5) but it is not going to be installed
         Recommends: apache2 but it is not going to be installed
         Recommends: ftp
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).




Gracias.
Un saludo.

Páginas: 1 2 [3]