Autor Tema: [Solucionado] Error en las unidades del pluviometro reportadas por weewx.  (Leído 1147 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado PacoVLC

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
  • Estación: ESCLM1300000013003A
Hola,
Como antecedentes este hilo:
http://forum.meteoclimatic.net/index.php/topic,987.15.html
Os pongo no obstante en antecedentes aquí,  el pluviómetro de Netatmo mide mm pero el weewx lo reporta creyéndose que son cm, con lo cual 10mm medidos se reportan como 100mm.
He modificado el archivo units.py tal y como indica aquí:
http://forum.meteoclimatic.net/index.php/topic,407.msg3343.html#msg3343
Pero sigue reportando mal.
Analizando el archivo he visto que dentro de "MetricWXUnits" está en cm.
Lo que he hecho es cambiar también"MetricWXUnits" a mm.

# This dictionary maps unit groups to a standard unit type in the
# "Metric WX" unit system. It's the same as the "Metric" system,
# except for rain and speed:
MetricWXUnits = ListOfDicts(MetricUnits)
MetricWXUnits['group_rain']     = "mm"
MetricWXUnits['group_rainrate'] = "mm_per_hour"
MetricWXUnits['group_speed']    = "meter_per_second"
MetricWXUnits['group_speed2']   = "meter_per_second2"


Me toca esperar al siguiente reporte.

Un saludo.
« Última modificación: 05 de Marzo del 2017, 09:07:09 am por PacoVLC »

Desconectado PacoVLC

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
  • Estación: ESCLM1300000013003A
Re:Error en las unidades del pluviometro reportadas por weewx.
« Respuesta #1 en: 17 de Diciembre del 2016, 17:00:58 pm »
Continúa reportando mal. El acumulado hoy es de 6,28mm y me pone 62,8mm
¿Puede tratarse de algún histórico que tenga el weewx y como ya almacenó el dato mal, aunque los nuevos los reporte bien, se acumula el error de antes?.

Desconectado Wlarues

  • Full Member
  • ***
  • Mensajes: 174
  • Estudiante de Física en la Universidad de Zaragoza
    • Ver Perfil
    • El tiempo en Larués
  • Estación: ESARA2200000022761B
Re:Error en las unidades del pluviometro reportadas por weewx.
« Respuesta #2 en: 17 de Diciembre del 2016, 17:19:02 pm »
Hola, yo creo que mucha casualidad sería que justo el factor sea x10 con el acumulado. Quizás el problema venga de que sea necesario reiniciar Weewx cuando se modifica el archivo de las unidades.

Yo probaría a cambiar las unidades a cm (como se indicaba en el post que has pasado) y reiniciar. A ver si así tiene efecto.
Si no se soluciona, entonces será el problema que dices de la base de datos.

Esto de las unidades de lluvia en Weewx, la verdad es que es poco intuitivo. En mi caso en la base de datos se guardan en cm (está todo dividido por 10) pero en mi página se muestran en mm.
Ahora no puedo comprobar cómo dejé el archivo de las unidades.

Saludos

Estación ESARA2200000022761B

Web Weewx: http://tiempo-larues.eu5.org

Desconectado PacoVLC

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
  • Estación: ESCLM1300000013003A
Re:Error en las unidades del pluviometro reportadas por weewx.
« Respuesta #3 en: 17 de Diciembre del 2016, 18:08:00 pm »
Hola, yo creo que mucha casualidad sería que justo el factor sea x10 con el acumulado. Quizás el problema venga de que sea necesario reiniciar Weewx cuando se modifica el archivo de las unidades.

Yo probaría a cambiar las unidades a cm (como se indicaba en el post que has pasado) y reiniciar. A ver si así tiene efecto.
Si no se soluciona, entonces será el problema que dices de la base de datos.

Esto de las unidades de lluvia en Weewx, la verdad es que es poco intuitivo. En mi caso en la base de datos se guardan en cm (está todo dividido por 10) pero en mi página se muestran en mm.
Ahora no puedo comprobar cómo dejé el archivo de las unidades.

Saludos

Gracias por la respuesta.
Siempre reinicio cada vez que modifico algún archivo.

jantoni

  • Visitante
Re:Error en las unidades del pluviometro reportadas por weewx.
« Respuesta #4 en: 17 de Diciembre del 2016, 18:32:27 pm »
Salvo que el usuario diga lo contrario, Weewx almacena en unidades imperiales y muestra en el formato seleccionado.

Lo que estáis indicando con esa modificación es como se muestra la información, no como se almacena.

Bien, con netatmo no se si funcionará bien el modo "live" o "en directo" para ver que unidades está leyendo weewx del driver.

Ya se ha indicado más de una vez como funcionar "en directo"

Si tenéis duda sobre como hacerlo, preguntar de nuevo o comprobar la documentación de weewx

jantoni

  • Visitante
Re:Error en las unidades del pluviometro reportadas por weewx.
« Respuesta #5 en: 17 de Diciembre del 2016, 18:36:44 pm »
Y ¿por qué 6,28mm?

Desconectado PacoVLC

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
  • Estación: ESCLM1300000013003A
Re:Error en las unidades del pluviometro reportadas por weewx.
« Respuesta #6 en: 17 de Diciembre del 2016, 20:01:34 pm »
Creo que lo que me estais pidiendo es esto.

He ejecutado:
sudo weewxd /etc/weewx/weewx.conf
y la respuesta es la siguiente:
 
LOOP:   2016-12-17 19:58:54 CET (1482001134) altimeter: 30.225150084, appTemp: None, barometer: 30.2712015309, cloudbase: 1968.50882971, co2: 19, dateTime: 1482001134, dewpoint: 47.84, heatindex: 47.84, humidex: 49.1789409915, inDewpoint: 52.0662736106, inHumidity: 60, inTemp: 66.38, maxSolarRad: None, noise: 44, out_battery_vp: 5382, out_rf_status: 55, outHumidity: 100, outTemp: 47.84, outTempBatteryStatus: 74, pressure: 28.147984085, rain: 0.0, rain_battery_vp: 6212, rain_rf_status: 63, rain_total: 6.363, rainBatteryStatus: 100, rainRate: 0, usUnits: 1, wifi_status: 34, windchill: None

Parece que mide bien pero sube los datos mal.

janotni Los 6,28 vienen por que es el total acumulado hoy que me daba en ese momento la aplicación de Netatmo.

jantoni

  • Visitante
Re:Error en las unidades del pluviometro reportadas por weewx.
« Respuesta #7 en: 17 de Diciembre del 2016, 20:39:31 pm »
Pues tendrás que forzar a ver cuanto mide en modo "live" con cada vuelco.

En caso de no encontrar el problema, podemos hacer un ajuste para dividir la lluvia por 10......pero me resulta raro que pase eso.

Leí hace poco que había un nuevo driver.

Si en modo "live" la cosa está bien, entonces el problema tiene que estar en el skin. Hay que recordar que meteoclimatic, en la mayoría de los casos, se alimenta del skin "standard"

También puedes verlo interrogando a la base de datos. Pero es más fácil verlo en el modo live

jantoni

  • Visitante
Re:Error en las unidades del pluviometro reportadas por weewx.
« Respuesta #8 en: 17 de Diciembre del 2016, 20:46:22 pm »
Por cierto, yo no he tocado nunca units.py ni nada parecido.

No sé realmente que provoca eso. Todo se puede cambiar desde weewx.conf y skin.conf

Evidentemente, de lo que no conozco no puedo hablar, y menos saber las consecuencias de tocar en dichos ficheros.

Desconectado PacoVLC

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
  • Estación: ESCLM1300000013003A
Re:Error en las unidades del pluviometro reportadas por weewx.
« Respuesta #9 en: 18 de Diciembre del 2016, 13:32:47 pm »
Buenos días,
He dejado todos los archivos de weewx como vienen en la instalación y ejecutado el modo live, el resultado de después de echar 100mL de agua y contar 60 vuelcos en el pluviómetro, el resultado a sido el siguiente:

LOOP:   2016-12-18 13:24:30 CET (1482063870) altimeter: 30.112502258, appTemp: None, barometer: 30.157652808, cloudbase: 2470.48354004, co2: 20, dateTime: 1482063870, dewpoint: 45.4513112745, heatindex: 47.66, humidex: 48.0141074487, inDewpoint: 46.3863236444, inHumidity: 52, inTemp: 64.4, maxSolarRad: None, noise: 42, out_battery_vp: 5384, out_rf_status: 55, outHumidity: 92, outTemp: 47.66, outTempBatteryStatus: 74, pressure: 28.04167613, rain: 0.238582677165, rain_battery_vp: 6204, rain_rf_status: 59, rain_total: 1.212, rainBatteryStatus: 100, rainRate: 0.954330708661, usUnits: 1, wifi_status: 20, windchill: None
REC:    2016-12-18 13:20:00 CET (1482063600) altimeter: 30.1187605931, appTemp: None, barometer: 30.1640044619, cloudbase: 2535.90846917, co2: 32.0, dateTime: 1482063600.0, dewpoint: 45.1634415864, ET: None, heatindex: 47.66, humidex: 47.9007562288, inDewpoint: 46.5525071263, inHumidity: 52.0, inTemp: 64.58, interval: 5, maxSolarRad: None, noise: 49.0, out_battery_vp: 5382.0, out_rf_status: 66.0, outHumidity: 91.0, outTemp: 47.66, outTempBatteryStatus: 74.0, pressure: 28.0475821275, rain: 0.0, rain_battery_vp: 6204.0, rain_rf_status: 65.0, rain_total: 0.0, rainBatteryStatus: 100.0, rainRate: 0.0, usUnits: 1, wifi_status: 22.0, windchill: None, windrun: 0.0

LOOP:   2016-12-18 13:29:30 CET (1482064170) altimeter: 30.112502258, appTemp: None, barometer: 30.157652808, cloudbase: 2470.48354004, co2: 20, dateTime: 1482064170, dewpoint: 45.4513112745, heatindex: 47.66, humidex: 48.0141074487, inDewpoint: 46.3863236444, inHumidity: 52, inTemp: 64.4, maxSolarRad: None, noise: 42, out_battery_vp: 5384, out_rf_status: 55, outHumidity: 92, outTemp: 47.66, outTempBatteryStatus: 74, pressure: 28.04167613, rain: 0.238582677165, rain_battery_vp: 6204, rain_rf_status: 59, rain_total: 1.212, rainBatteryStatus: 100, rainRate: 1.90866141732, usUnits: 1, wifi_status: 20, windchill: None
REC:    2016-12-18 13:25:00 CET (1482063900) altimeter: 30.112502258, appTemp: None, barometer: 30.157652808, cloudbase: 2470.48354004, co2: 20.0, dateTime: 1482063900.0, dewpoint: 45.4513112745, ET: None, heatindex: 47.66, humidex: 48.0141074487, inDewpoint: 46.3863236444, inHumidity: 52.0, inTemp: 64.4, interval: 5, maxSolarRad: None, noise: 42.0, out_battery_vp: 5384.0, out_rf_status: 55.0, outHumidity: 92.0, outTemp: 47.66, outTempBatteryStatus: 74.0, pressure: 28.04167613, rain: 0.238582677165, rain_battery_vp: 6204.0, rain_rf_status: 59.0, rain_total: 1.212, rainBatteryStatus: 100.0, rainRate: 0.954330708661, usUnits: 1, wifi_status: 20.0, windchill: None, windrun: 0.0


Voy a volver a medir para calibrar el pluvio, ya que eché demasiado rápido el agua y creo que me salté algún vuelco, conté 60 pero me pude saltar alguno jejeje  :)

Desconectado PacoVLC

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
  • Estación: ESCLM1300000013003A
Re:Error en las unidades del pluviometro reportadas por weewx.
« Respuesta #10 en: 18 de Diciembre del 2016, 13:51:00 pm »
Ya he recalibrado el pluvio tal y como dice el fabricante, 100mL han provocado 69 vuelcos, 100/69=1.44.
Ahora solo me falta solucionar las medidas reportadas.

Desconectado PacoVLC

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
  • Estación: ESCLM1300000013003A
Re:Error en las unidades del pluviometro reportadas por weewx.
« Respuesta #11 en: 27 de Enero del 2017, 14:57:16 pm »
Hola compañer@s.
Sigo teniendo el problema de los reportes en el pluviómetro.
He modificado en skin.conf como me recomendaron, poniendo cm, pero no se soluciona.
En modo live lo reporta bien, pero luego al subirlo tanto a la web como al servidor de CWOP lo reporta mal.
Lo que hace es multiplicar la cifra por 10.
Alguna solución se os ocurre.
Un saludo.
Gracias.

Desconectado PacoVLC

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
  • Estación: ESCLM1300000013003A
Re:Error en las unidades del pluviometro reportadas por weewx.
« Respuesta #12 en: 05 de Marzo del 2017, 09:06:31 am »
Solucionado modificando skin en el weewx. conf:

    [[[Units]]]
            [[[[Groups]]]]
                group_altitude = meter
                group_speed2 = meter_per_second2
                group_pressure = mbar
                group_rain = cm
                group_rainrate = cm_per_hour
                group_temperature = degree_C
                group_degree_day = degree_C_day
                group_speed = meter_per_second