Autor Tema: No tengo carpeta /var/www/html/weewx  (Leído 13759 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.236
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:No tengo carpeta /var/www/html/weewx
« Respuesta #30 en: 27 de Enero del 2018, 12:09:38 pm »
Hola GarciaMiguel

Tiene pinta de no estar apache2 en funcionamiento...

prueba con sudo service apache2 status

Si no está en funcionamiento... es raspbian stretch el SO ??
« Última modificación: 27 de Enero del 2018, 12:23:50 pm por jmviper »


Archena, Valle de Ricote (Murcia). 120 msnm. 19.500 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es

Desconectado GarciaMiguel

  • Newbie
  • *
  • Mensajes: 34
    • Ver Perfil
  • Estación: ESAND1800000018410A
Re:No tengo carpeta /var/www/html/weewx
« Respuesta #31 en: 27 de Enero del 2018, 12:50:57 pm »
Hola, gracias por la respuesta.

Ahora sí que me ha generado la carpeta /ets/www/ , aunque le ha costado 3 horas (contadas)...

pi@raspberrypi:~ $ sudo service apache2 status
● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; ve
   Active: active (running) since Sat 2018-01-27 10:37:17 UTC; 1h 4
  Process: 1518 ExecStop=/usr/sbin/apachectl stop (code=exited, sta
  Process: 1525 ExecStart=/usr/sbin/apachectl start (code=exited, s
 Main PID: 1530 (apache2)
   CGroup: /system.slice/apache2.service
           ├─1530 /usr/sbin/apache2 -k start
           ├─1532 /usr/sbin/apache2 -k start
           └─1533 /usr/sbin/apache2 -k start

ene 27 10:37:17 raspberrypi systemd[1]: Starting The Apache HTTP Se
ene 27 10:37:17 raspberrypi apachectl[1525]: AH00558: apache2: Coul
ene 27 10:37:17 raspberrypi systemd[1]: Started The Apache HTTP Ser
...skipping...
● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; ve
   Active: active (running) since Sat 2018-01-27 10:37:17 UTC; 1h 4
  Process: 1518 ExecStop=/usr/sbin/apachectl stop (code=exited, sta
  Process: 1525 ExecStart=/usr/sbin/apachectl start (code=exited, s
 Main PID: 1530 (apache2)
   CGroup: /system.slice/apache2.service
           ├─1530 /usr/sbin/apache2 -k start
           ├─1532 /usr/sbin/apache2 -k start
           └─1533 /usr/sbin/apache2 -k start

ene 27 10:37:17 raspberrypi systemd[1]: Starting The Apache HTTP Se
ene 27 10:37:17 raspberrypi apachectl[1525]: AH00558: apache2: Coul
ene 27 10:37:17 raspberrypi systemd[1]: Started The Apache HTTP Ser
~


Lo que no me genera es ningún aechvo weewx dado que la consola no está conectada y el log me da error de conexión con la consola, ¿es correcto? ¿o debería generar algo igualmente?

Jan 27 08:32:05 raspberrypi weewx[366]: Starting weewx weather system: weewxerror: unexpectedly disconnected from boot status daemon
Jan 27 08:32:06 raspberrypi weewx[525]: engine: Initializing weewx version 3.8.0
Jan 27 08:32:06 raspberrypi weewx[525]: engine: Using Python 2.7.13 (default, Nov 24 2017, 17:33:09) #012[GCC 6.3.0 20170516]
Jan 27 08:32:06 raspberrypi weewx[525]: engine: Platform Linux-4.9.59-v7+-armv7l-with-debian-9.3
Jan 27 08:32:06 raspberrypi weewx[525]: engine: Locale is 'en_GB.UTF-8'
Jan 27 08:32:06 raspberrypi weewx[525]: engine: pid file is /var/run/weewx.pid
Jan 27 08:32:06 raspberrypi weewx[366]: .
Jan 27 08:32:06 raspberrypi weewx[539]: engine: Using configuration file /etc/weewx/weewx.conf
Jan 27 08:32:06 raspberrypi weewx[539]: engine: Loading station type Vantage (weewx.drivers.vantage)
Jan 27 08:32:06 raspberrypi weewx[539]: import of driver failed: [Errno 2] could not open port /dev/ttyUSB0: [Errno 2] No such file or directory: '/dev/ttyUSB0' (<class 'serial.serialutil.SerialException'>)
Jan 27 08:32:06 raspberrypi weewx[539]: engine: Unable to load driver: [Errno 2] could not open port /dev/ttyUSB0: [Errno 2] No such file or directory: '/dev/ttyUSB0'
Jan 27 08:32:06 raspberrypi weewx[539]:     ****  Exiting...


Lo que sí me sigue saliendo:

pi@raspberrypi:~ $ php --version
-bash: php: no se encontró la orden


Muchas gracias.

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.617
    • Ver Perfil
    • Rivas-Vaciamadrid Centro
  • Estación: ESMAD2800000028522A
Re:No tengo carpeta /var/www/html/weewx
« Respuesta #32 en: 27 de Enero del 2018, 13:48:47 pm »
Si no decís que tipo de imagen habéis cargado es muy complicado el ayudar

EN RASPBERRY PI SIEMPRE HAY QUE USAR LA IMAGEN RASPBIAN LITERAL

Dejad ya de usar la cosa esa de NOOBBS.

Por otro lado, ojo no es necesario usarlo con sudo.

Si php no se ejecuta, es que no está instalado, aunque no es estrictamente necesario.

Para instalarlo habrá que hacerlo de la forma tradicional

sudo apt install php5

En cuanto a los directorios, no se a que os referís. Tenéis que ser un poco más explícitos en los mensajes. Mis dotes de adivino se han ido gastando con la edad.

Saludos
Las opiniones que pueda escribir no suponen asesoramiento profesional. Cada usuario tomará sus decisiones bajo su propio riesgo.

Desconectado GarciaMiguel

  • Newbie
  • *
  • Mensajes: 34
    • Ver Perfil
  • Estación: ESAND1800000018410A
Re:No tengo carpeta /var/www/html/weewx
« Respuesta #33 en: 27 de Enero del 2018, 16:20:57 pm »
Hola.

Gracias por responder, y perdona la imprecisión.

Cargué la imagen de Raspbian Stretch with desktop de https://www.raspberrypi.org/downloads/raspbian/ y después descargué y ejecuté tu script http://jantoni.no-ip.org/download/raspweather/weewx.sh

No me instala php:

pi@raspberrypi:~ $ sudo apt install php5
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
El paquete php5 no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente

E: El paquete «php5» no tiene un candidato para la instalación
pi@raspberrypi:~ $


Respecto a la no existencia de la carpeta /etc/www/, ya está solucionado dado que apache2 lo he instalado y funciona. Lo que no se me crean son las pàginas con los datos (index.htm, etc.) o la plantilla de meteoclimatic.htm , que yo creo que es porque la raspberry no está conectada a la consola de la estación, y me da los errores indicados en el mensaje anterior de que no encuentra la estación. No sé como cambiar a modo simulador en weewx.conf para poder probarlo.

Gracias.

Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.236
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:No tengo carpeta /var/www/html/weewx
« Respuesta #34 en: 27 de Enero del 2018, 16:32:29 pm »
Creo que php5 no está en el repositorio para la Raspbian de Stretch... prueba con php 7...

sudo apt-get install php7.0


Archena, Valle de Ricote (Murcia). 120 msnm. 19.500 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es

Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.236
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:No tengo carpeta /var/www/html/weewx
« Respuesta #35 en: 27 de Enero del 2018, 16:37:43 pm »
Y por lo que te dice weewx está intentado cargar el driver de la vantage y al no tener nada conectado pues se sale.

Si lo pones en modo simulador si no recoge datos de ningún sitio no creo que tampoco escriba ni genere nada.


Archena, Valle de Ricote (Murcia). 120 msnm. 19.500 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es

Desconectado GarciaMiguel

  • Newbie
  • *
  • Mensajes: 34
    • Ver Perfil
  • Estación: ESAND1800000018410A
Re:No tengo carpeta /var/www/html/weewx
« Respuesta #36 en: 27 de Enero del 2018, 17:14:01 pm »
Muchas gracias.

Ahora con php7 y en modo simulador ya me lo ha generado todo, muchas gracias.
 plau2