Autor Tema: Raspberry PI 3b con PCE-FWS-20  (Leído 11351 veces)

0 Usuarios y 2 Visitantes están viendo este tema.

Desconectado Giroquim

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Estación: En Proyecto
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #15 en: 21 de Enero del 2018, 08:31:34 am »
Buenos días,

Seguimos igual, la versión instalada siempre es la más reciente:

pi@raspberrypi:~ $ mono --version
Mono JIT compiler version 4.6.2 (Debian 4.6.2.7+dfsg-1)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
   TLS:           normal
   SIGSEGV:       normal
   Notifications: epoll
   Architecture:  armel,vfp+hard
   Disabled:      none
   Misc:          softdebug
   LLVM:          supported, not enabled.
   GC:            sgen

He probado introduciendole el comando que habías comentado anteriormente,

echo "deb http://download.mono-project.com/repo/debian wheezy/snapshots/3.8.0 main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list

que debería cambiar la versión de instalación entiendo, pero tampoco. Me he fijado que en este comando pones 3.8.0 y tu comentabas de instalar la 3.2.8, puede ser esto? En resumen, por lo poco que entiendo de Linux, veo que se desintala correctamente el mono, porqué una vez eliminado me ha salido esto:

pi@raspberrypi:~ $ sudo apt-get remove mono-complete
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'mono-complete' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 168 not upgraded.

Así que el problema está en que no consigo instalar una version anterior de MONO.

Gracias por la ayuda

Desconectado Giroquim

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Estación: En Proyecto
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #16 en: 21 de Enero del 2018, 09:49:19 am »
Hola jmviper,

He instalado directamente la versión más reciente que consta en la página oficial de MONO Project, siguiendo sus comandos, es la versión 5.4,  pero seguimos igual FINE OFFSET NOT FOUND:

pi@raspberrypi:~ $ mono --version
Mono JIT compiler version 5.4.1.7 (tarball Wed Jan 17 21:57:12 UTC 2018)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
   TLS:           __thread
   SIGSEGV:       normal
   Notifications: epoll
   Architecture:  armel,vfp+hard
   Disabled:      none
   Misc:          softdebug
   LLVM:          supported, not enabled.
   GC:            sgen (concurrent by default)
pi@raspberrypi:~ $ cd /home/pi/CumulusMX
pi@raspberrypi:~/CumulusMX $ sudo mono CumulusMX.exe
Current culture: English (United Kingdom)
Serial: 74FECEABEB2DA94ECB5EBA0CD11A7137
Cumulus MX v.3.0.0 build 3043
Today.ini = data/today.ini
Last update=2018-01-21T09:46:30
Looking for Fine Offset station, VendorID=0x1941 ProductID=0x8021
System.MissingMethodException: Method 'Mono.Unix.Native.Syscall.uname' not found.
  at System.RuntimeType.InvokeMember (System.String name, System.Reflection.BindingFlags bindingFlags, System.Reflection.Binder binder, System.Object target, System.Object[] providedArgs, System.Reflection.ParameterModifier[] modifiers, System.Globalization.CultureInfo culture, System.String[] namedParams) [0x0070c] in <885b6d97fbc743558f4bb402a2f41b55>:0
  at System.Type.InvokeMember (System.String name, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object target, System.Object[] args, System.Globalization.CultureInfo culture) [0x00000] in <885b6d97fbc743558f4bb402a2f41b55>:0
  at HidSharp.Platform.Linux.NativeMethods.uname (System.String& sysname, System.String& release, System.String& machine) [0x00047] in <ae7920a0f15c43d292a5cc3a2fd0a936>:0
  at HidSharp.Platform.Linux.NativeMethods.uname (System.String& sysname, System.Version& release, System.String& machine) [0x00004] in <ae7920a0f15c43d292a5cc3a2fd0a936>:0
  at HidSharp.Platform.Linux.LinuxHidManager.get_IsSupported () [0x00002] in <ae7920a0f15c43d292a5cc3a2fd0a936>:0
Not supported
Fine Offset station not found
Cumulus running at: http://*:8998/
(Replace * with any IP address on this machine, or localhost)
Starting web socket server on port 8002
21/01/2018 09:46:31
Type Ctrl-C to terminate


Creo que lo suyo sería conseguir instalar una versión anterior que sepamos que funciona correctamente con CumulusMX. Porqué una pregunta, la versión estándar de Cumulus no funciona con Raspbian verdad?


Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.834
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #17 en: 21 de Enero del 2018, 11:05:44 am »

Creo que lo suyo sería conseguir instalar una versión anterior que sepamos que funciona correctamente con CumulusMX. Porqué una pregunta, la versión estándar de Cumulus no funciona con Raspbian verdad?


Cumulus MX necesita .NET framework de Microsoft para funcionar y por eso necesita mono (que es una implementación de código abierto) para ser ejecutado.

Yo tampoco sé demasiado de Linux, lo justo para defenderme, así que googleando a ver si somos capaces de llegar a hacerlo así que haz una cosa:

ejecuta sudo apt-cache policy mono-complete

y pon el resultado a ver qué versiones de mono hay para instalar.



Archena, Valle de Ricote (Murcia). 120 msnm. 19.428 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es

Desconectado Giroquim

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Estación: En Proyecto
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #18 en: 21 de Enero del 2018, 22:15:29 pm »
esto es lo que reporta:

i@raspberrypi:~ $ sudo apt-cache policy mono-complete
mono-complete:
  Installed: (none)
  Candidate: 5.4.1.7-0xamarin1+raspbian9b1
  Version table:
     5.4.1.7-0xamarin1+raspbian9b1 500
        500 http://download.mono-project.com/repo/debian raspbianstretch/main armhf Packages
     4.6.2.7+dfsg-1 500
        500 http://mirrordirector.raspbian.org/raspbian stretch/main armhf Packages

Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.834
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #19 en: 22 de Enero del 2018, 00:09:50 am »
No sé si se ha trastocado algo... ejecuta:

echo "deb http://download.mono-project.com/repo/debian wheezy/snapshots/3.8.0 main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list

sudo apt-get update

sudo apt-cache policy mono-complete


Mira a ver qué tienes en /etc/apt/sources.list.d con ls /etc/apt/sources.list.d


Archena, Valle de Ricote (Murcia). 120 msnm. 19.428 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es

Desconectado Giroquim

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Estación: En Proyecto
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #20 en: 22 de Enero del 2018, 07:55:31 am »
Ahí va:

pi@raspberrypi:~ $ mono --version
bash: /usr/bin/mono: No such file or directory
pi@raspberrypi:~ $ echo "deb http://download.mono-project.com/repo/debian wheezy/snapshots/3.8.0 main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list
deb http://download.mono-project.com/repo/debian wheezy/snapshots/3.8.0 main
pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease                                                                                                                 
Get:3 http://download.mono-project.com/repo/debian raspbianstretch InRelease [2,224 B]                                                                                   
Get:4 http://download.mono-project.com/repo/debian wheezy/snapshots/3.8.0 InRelease [2,885 B]                                                     
Ign:5 http://linux.teamviewer.com/deb stable InRelease                                                     
Hit:6 http://weewx.com/apt squeeze InRelease                             
Ign:7 http://linux.teamviewer.com/deb preview InRelease                 
Get:8 http://linux.teamviewer.com/deb stable Release [6,064 B]
Get:9 http://linux.teamviewer.com/deb preview Release [6,014 B]
Get:10 http://linux.teamviewer.com/deb stable Release.gpg [836 B]
Get:11 http://linux.teamviewer.com/deb preview Release.gpg [836 B]
Ign:3 http://download.mono-project.com/repo/debian raspbianstretch InRelease
Ign:4 http://download.mono-project.com/repo/debian wheezy/snapshots/3.8.0 InRelease
Get:12 http://linux.teamviewer.com/deb stable/main armhf Packages [1,925 B]
Get:13 http://linux.teamviewer.com/deb preview/main armhf Packages [1,685 B]
Fetched 22.5 kB in 3s (6,177 B/s)     
Reading package lists... Done
W: GPG error: http://download.mono-project.com/repo/debian raspbianstretch InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A6A19B38D3D831EF
W: The repository 'http://download.mono-project.com/repo/debian raspbianstretch InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://download.mono-project.com/repo/debian wheezy/snapshots/3.8.0 InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A6A19B38D3D831EF
W: The repository 'http://download.mono-project.com/repo/debian wheezy/snapshots/3.8.0 InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Skipping acquire of configured file 'main/binary-armhf/Packages' as repository 'http://download.mono-project.com/repo/debian wheezy/snapshots/3.8.0 InRelease' doesn't support architecture 'armhf'
pi@raspberrypi:~ $ sudo apt-cache policy mono-complete
mono-complete:
  Installed: (none)
  Candidate: 5.4.1.7-0xamarin1+raspbian9b1
  Version table:
     5.4.1.7-0xamarin1+raspbian9b1 500
        500 http://download.mono-project.com/repo/debian raspbianstretch/main armhf Packages
     4.6.2.7+dfsg-1 500
        500 http://mirrordirector.raspbian.org/raspbian stretch/main armhf Packages
pi@raspberrypi:~ $ /etc/apt/sources.list.d con ls /etc/apt/sources.list.d
bash: /etc/apt/sources.list.d: Is a directory
pi@raspberrypi:~ $ ls /etc/apt/sources.list.d
mono-official.list  mono-xamarin.list  raspi.list  teamviewer.list  weewx.list
pi@raspberrypi:~ $

Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.834
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #21 en: 22 de Enero del 2018, 12:28:35 pm »
Ok por partes...una imagen vale más que mil palabras por lo que has hecho muy bien en volcar el resultado de apt-get update

El principal problema es que la versión de mono 3.8.0 no tiene paquete para la arquitectura armhf que es la de las raspis y probando he visto que la 3.12.0 (en verdad se instala la 3.12.1) va bien y tiene paquete para armhf. Así que vamos a hacer lo siguiente:

Vamos a ejecutar:

sudo rm /etc/apt/sources.list.d/mono-oficial.list (no queremos actualizar mono a la última versión)

echo "deb http://download.mono-project.com/repo/debian wheezy/snapshots/3.12.0 main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list

desinstalamos el actual mono:

sudo apt-get purge mono-*

parece que hay problemas de llaves de mono así que instalamos la que ponen en su página:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF

sudo apt-get clean

y actualizamos con:

sudo apt-get update

sudo apt-cache policy mono-complete

Si te sale 3.12.1-0xamarin1 estamos de enhorabuena  :) así que hacemos

He encontrado problemas de dependencias con apt-get que no me dejaba instalarlo por lo que lo he hecho con aptitude que resuelve mejor esos problemas:

sudo aptitude install mono-complete=3.12.1-0xamarin1

y supuestamente aptitude nos instalará mono-complete 3.12.1

Tras terminar verificamos que versión tenemos de mono con mono -V

Si la tenemos ya podemos ejecutar CumulusMX.

Resulta curioso... yo tengo una Orange Pi... de hecho todo esto lo estoy probando en ella y en el repositorio de armbian viene la 3.2.8 y ejecutaba Cumulus MX y podía acceder a él a través de la IP de la Orange. Descargaba del datalogger de la Davis y se quedaba funcionando pero en la página no se actualizaban los datos ni por websockets que vienen por defecto ni por Ajax.
He instalado esta versión de mono 3.12.1 y si van ya los datos en la página :D :D

Si consigues instalarlo y que funcione no hagas un apt-get update o podrá machar la versión de mono con una más nueva. Habrá que marcar la versión que nos va para que no la actualice del repositorio de la raspberry y también he visto un script bash para dejar a Cumulus MX como si de un servicio Linux (daemon) se tratase. Se descarga de la siguiente página:

http://jankreutzer.de/index.php/software/raspberrypi/cumulusmx-start-stop-script.html

Ahí se encuentran las instrucciones y la descarga al final de la página.

A ver si logramos hacer funcionar el tuyo  :)





« Última modificación: 22 de Enero del 2018, 14:30:07 pm por jmviper »


Archena, Valle de Ricote (Murcia). 120 msnm. 19.428 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es

Desconectado Giroquim

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Estación: En Proyecto
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #22 en: 22 de Enero del 2018, 17:18:59 pm »
Fantástico trabajo jmviper, se ha instalado la versión 3.12.1, pero aún así sigue sin detectarme la estación meteo...

pi@raspberrypi:~/CumulusMX $ mono --version
Mono JIT compiler version 3.12.1 (tarball Fri Mar  6 23:28:08 UTC 2015)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
   TLS:           __thread
   SIGSEGV:       normal
   Notifications: epoll
   Architecture:  armel,vfp+hard
   Disabled:      none
   Misc:          softdebug
   LLVM:          supported, not enabled.
   GC:            sgen
pi@raspberrypi:~/CumulusMX $ ^C
pi@raspberrypi:~/CumulusMX $ cd /home/pi/CumulusMX
pi@raspberrypi:~/CumulusMX $ sudo mono CumulusMX.exe
Current culture: English (United Kingdom)
Serial: 74FECEABEB2DA94ECB5EBA0CD11A7137
Cumulus MX v.3.0.0 build 3043
Today.ini = data/today.ini
Last update=2018-01-22T17:16:31
Looking for Fine Offset station, VendorID=0x1941 ProductID=0x8021
sysname=Linux release=4.9.41 machine=armv7l
Fine Offset station not found
Cumulus running at: http://*:8998/
(Replace * with any IP address on this machine, or localhost)
Starting web socket server on port 8002
22/01/2018 17:16:31
Type Ctrl-C to terminate

Alguna otra idea? Como decía anteriormente, conectandola a Windows y NETframework funciona correctamente con el CumulusMX, quizá probaré de reinstalar el CumulusMX.

Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.834
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #23 en: 22 de Enero del 2018, 17:32:38 pm »
Hola jmviper, sale esto:

Bus 001 Device 004: ID 1a81:1006 Holtek Semiconductor, Inc.
Bus 001 Device 009: ID 1941:8021 Dream Link WH1080 Weather Station / USB Missile Launcher
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

he ejecutado también el comando que comentas


Según lo que pusiste que te salía con lsusb te sale lo del 1941:8021 por lo que está ahí.

Primero intenta configurar la estación en la página de cumulus MX y si aún así sigue sin encontrarla borra Cumulus.ini de la instalación y prueba a ponerlo en marcha. Puede que esté leyendo la configuración de ese Cumulus.ini que tenías en Windows y de ese error al mirar en puertos/rutas que no son de la raspi.





Archena, Valle de Ricote (Murcia). 120 msnm. 19.428 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es

Desconectado Giroquim

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Estación: En Proyecto
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #24 en: 23 de Enero del 2018, 14:43:03 pm »
Hola Jmviper,

Muchísimas gracias por tu ayuda, hasta el momento he conseguido instalar correctamente la versión de MONO 3.12.1, pero aún así, borrando el fichero Cumulus.ini e incluso instalando CumulusMX de nuevo, sigue sin detectar la estación meteo.

Por el foro la página web de Sandaysoft comentan de instalar una versión conocida de Raspbian que ya incluye MONO instalado y que se comenta que funciona, en cuanto tenga un poco de tiempo lo pruebo y os digo.

Gracias por la ayuda, cualquier sugerencia mientrastanto será bienvenida.

Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.834
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #25 en: 23 de Enero del 2018, 17:03:36 pm »
Yo por mi parte he estado probando... en la Orange Pi tenía Cumulus MX funcionando con la Davis por TCP/IP a través de Virtual VP e iba bien así que le he metido la Davis directamente y en /dev me ha salido el puerto ttyUSB0 por lo que he puesto en la configuración el puerto /dev/ttyUSB0 y a conectado a la primera.

Tengo también una Oregon WMR100N y con ella las pruebas han sido negativas... no la detecta (WMR100 station not found !) y he intentado ponerle todos los puertos posibles (/dev/usbdev6.1 , /dev/bus/usb/006/001 , /dev/usb/hiddendev1) sin ningún éxito por lo que he desistido... sobre todo porque creo que debería de encontrarla a la primera sin tenerle que poner ningún puerto ya que creo que eso es sólo para las Davis y alguna estación más que funcione en serie.

No sé si será la versión de mono que tendrá que ser una específica (parece que en el foro de Sandaysoft los testers probaron con mono 3.2.8 ) o es algo del sistema operativo.

Puedes probar diferentes cosas y plantearlo en el foro de Cumulus. Ahí hay gente que sabe del tema lo más seguro. Lástima que Cumulus esté descontinuado ya que su creador se ha tomado unas laaaaaargas vacaciones (de hecho no se sabe si volverá a desarrollar Cumulus).

La otra opción para la Raspi es Weewx el cual tengo también funcionando con la Davis y el cual ha conectado con la Oregon a la primera sin tener que poner puerto.

Encantados estaremos de que hayas podido dar con la solución y la compartas con los que nos gusta trastear o que quieran usar Cumulus MX en su Raspi con una PCE  :)

Saludos


Archena, Valle de Ricote (Murcia). 120 msnm. 19.428 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es

Desconectado Giroquim

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Estación: En Proyecto
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #26 en: 23 de Enero del 2018, 23:14:36 pm »
Un compañero del foro de Sandaysoft ha escrito este "step by step" para la instalación de la versión de MONO correcta, hay varios comentarios que corroboran que les funciona con una PCE. Adjunto link:

http://sandaysoft.com/forum/viewtopic.php?f=27&t=13587&start=30

es la entrada de:  Steen9542 » Tue Oct 10, 2017 1:23 pm

Por mi parte he vuelto a poner una versión nueva de Raspbian Stretch (con formateo de SD incluido). Las raspi arranca correctamente, actualizo con los comandos:

$ sudo apt-get update
$ sudo apt-get dist-upgrade


Luego reinicio la raspi y el siguiente paso es añadir la línea para la versión de MONO deseada:

Add the mono repository:
$ cd /etc/apt/sources.list.d
$ sudo vi mono-xamarin.list
add below line:
deb http://download.mono-project.com/repo/debian wheezy/snapshots/4.0.5 main


Ahí es donde me lío, será una tontería pero tras varios intentos no consigo añadir la línea mencionada a la lista, no acabo de entender como debería hacerlo.
jmviper puedes ayudarme en esta paso?

Gracias!

Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.834
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #27 en: 24 de Enero del 2018, 00:09:45 am »
Sabes buscar bien  :) :)

Lo hemos hecho anteriormente varias veces. No hace falta editar el archivo, simplemente pon en el símbolo del sistema:

echo "deb http://download.mono-project.com/repo/debian wheezy/snapshots/4.0.5 main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list

No me imaginaba que una versión superior a la que habíamos puesto funcionase... a ver si esta es la buena


Archena, Valle de Ricote (Murcia). 120 msnm. 19.428 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es

Desconectado Giroquim

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Estación: En Proyecto
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #28 en: 24 de Enero del 2018, 00:14:17 am »
BINGO! al final he editado la lista de MONO con algunos comandos que he encontrado por la red, no había visto tu comentario, supongo que también serviría.

Ya tengo la estacíon meteo conectada a CUMULUSMX!

Muchas gracias por tu ayuda jmviper, eres un crack.

Saludos,

Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.834
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:Raspberry PI 3b con PCE-FWS-20
« Respuesta #29 en: 24 de Enero del 2018, 00:16:31 am »
 apla3 apla3 apla3 apla3

El mérito es tuyo... el que la sigue la consigue  ;)

Yo voy a probarla y a ver si conecta con la Oregon en Armbian Jessie. Mañana contaré que ya es muy tarde.

Saludos y a disfrutarla


Archena, Valle de Ricote (Murcia). 120 msnm. 19.428 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es