Autor Tema: Problema con envío de datos mediante Utilidad Linux  (Leído 3104 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado JavierGP

  • Newbie
  • *
  • Mensajes: 3
    • Ver Perfil
Problema con envío de datos mediante Utilidad Linux
« en: 22 de Noviembre del 2015, 17:30:26 pm »
Buenas tardes, mi problema es que mis datos no se suben correctamente a meteoclimatic, aunque la plantilla si actualiza correctamente.
Tengo una Davis Vantage Vue conectada a una Raspberry Pi 2 y mediante el software Weewx.

He utilizado el programa modificado por ti: meteoclimatic_http.php

Únicamente ha habido dos actualizaciones que las ha hecho correctamente, las restantes se mantienen igual.
Por lo que he podido observar, todos los parámetros los actualiza bien, excepto la temperatura actual, que sólo la actualiza en grados, no aparecen las décimas en Meteoclimatic.

Aquí te pongo Jantoni lo que me has pedido, el /etc/weewx/skins/Standard/meteoclimatic.htm.tmpl

*VER=DATA2
*COD=ESCLM4500000045600D
*SIG=
*UPD=$current.dateTime.format("%d-%m-%Y %H:%M")
*TMP=$current.outTemp.formatted
*WND=$current.windSpeed.formatted
*AZI=$current.windDir.formatted
*BAR=$current.barometer.formatted
*HUM=$current.outHumidity.formatted
*SUN=$current.radiation.formatted
*UVI=$current.UV.formatted
*DHTM=$day.outTemp.max.formatted
*DLTM=$day.outTemp.min.formatted
*DHHM=$day.outHumidity.max.formatted
*DLHM=$day.outHumidity.min.formatted
*DHBR=$day.barometer.max.formatted
*DLBR=$day.barometer.min.formatted
*DGST=$day.windGust.max.formatted
*DSUN=$day.radiation.max.formatted
*DHUV=$day.UV.max.formatted
*DPCP=$day.rain.sum.formatted
*WRUN=
*MHTM=$month.outTemp.max.formatted
*MLTM=$month.outTemp.min.formatted
*MHHM=$month.outHumidity.max.formatted
*MLHM=$month.outHumidity.min.formatted
*MHBR=$month.barometer.max.formatted
*MLBR=$month.barometer.min.formatted
*MGST=$month.windGust.max.formatted
*MSUN=$month.radiation.max.formatted
*MHUV=$month.UV.max.formatted
*MPCP=$month.rain.sum.formatted
*YHTM=$year.outTemp.max.formatted
*YLTM=$year.outTemp.min.formatted
*YHHM=$year.outHumidity.max.formatted
*YLHM=$year.outHumidity.min.formatted
*YHBR=$year.barometer.max.formatted
*YLBR=$year.barometer.min.formatted
*YGST=$year.windGust.max.formatted
*YSUN=$year.radiation.max.formatted
*YHUV=$year.UV.max.formatted
*YPCP=$year.rain.sum.formatted
*EOT*
© jantoni (02/2015)

Muchas gracias de antemano. Un saludo
« Última modificación: 22 de Noviembre del 2015, 19:39:05 pm por JavierGP »

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.816
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Problema con envío de datos mediante Utilidad Linux
« Respuesta #1 en: 22 de Noviembre del 2015, 20:34:56 pm »
Ummmm.....no sé....he visto este comportamiento antes.

Antes de mirar la posible solución, vas a reiniciar la raspberry y me cuentas luego.

El problema viene por las comas o puntos decimales de la plantilla de Meteoclimatic. Lo que ví en tu privado está bien. Por lo que vamos a reiniciar la raspi a ver que ocurre....a mi me ha ocurrido una vez y me volví loco.

La explicación es la siguiente: Meteoclimatic tiene un sistema, para mi gusto, muy complicado de recibir los datos. Se reciben multiplicados por 10 y, luego, el robot de Meteoclimatic lo divide por 10 para procesarlo. Con las comas y puntos decimales, los programas que lo multiplican, se hacen un lío impresionante, haciendo cosas rarísimas.

Desconectado JavierGP

  • Newbie
  • *
  • Mensajes: 3
    • Ver Perfil
Re:Problema con envío de datos mediante Utilidad Linux
« Respuesta #2 en: 27 de Noviembre del 2015, 11:14:52 am »
Para mi sorpresa, sin haber reiniciado ni modificado nada en la Raspberry, mi estación de Meteoclimatic actualiza sin ningún tipo de error desde ayer.

Esperemos que dure mucho tiempo. Muchas gracias Jantoni por tu interés.

Un saludo