Autor Tema: He perdido la precipitación de ayer  (Leído 1438 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado maxworld

  • Newbie
  • *
  • Mensajes: 29
    • Ver Perfil
  • Estación: ESAND2300000023320B
He perdido la precipitación de ayer
« en: 24 de Mayo del 2021, 09:47:23 am »
Buenos días

Hace poco hubo unos cambios que parece ser que realizasteis el otro día, yo tenía el horario civil configurado y la preci llegaba a las 00 correctamente. Ayer, los 5.7 mm que cayeron se han perdido, bueno sale un vuelco de 0.5 mm a última hora. ¿Sabéis que ha podido pasar? . ¿Tengo que hacer algún cambio en la consola?  yo tengo HC puesto después de la contraseña y Horario Civil configurado en la plantilla.


Gracias
Un saludo

Desconectado maxworld

  • Newbie
  • *
  • Mensajes: 29
    • Ver Perfil
  • Estación: ESAND2300000023320B
Re:He perdido la precipitación de ayer
« Respuesta #1 en: 24 de Mayo del 2021, 11:40:49 am »
Buenos días

Hace poco hubo unos cambios que parece ser que realizasteis el otro día, yo tenía el horario civil configurado y la preci llegaba a las 00 correctamente. Ayer, los 5.7 mm que cayeron se han perdido, bueno sale un vuelco de 0.5 mm a última hora. ¿Sabéis que ha podido pasar? . ¿Tengo que hacer algún cambio en la consola?  yo tengo HC puesto después de la contraseña y Horario Civil configurado en la plantilla.


Gracias
Un saludo
Me autocito. Me acabo de encontrar la plantilla configurada en UTC :o , juro que yo no la he tocado. La he cambiado a Civil. ¿Hay que hacer algo mas en la estación?

Desconectado casacota

  • Moderador Global
  • Hero Member
  • *****
  • Mensajes: 1.041
    • Ver Perfil
    • Observatori de Sant Martí de Canals
  • Estación: Sant Martí de Canals ESCAT2500000025518A
Re:He perdido la precipitación de ayer
« Respuesta #2 en: 24 de Mayo del 2021, 14:02:06 pm »
Me autocito. Me acabo de encontrar la plantilla configurada en UTC :o , juro que yo no la he tocado. La he cambiado a Civil. ¿Hay que hacer algo mas en la estación?

Puede que haya sido error por mi parte. Si es así pido disculpas. He tenido que adaptar un montón de estaciónes y es posible que haya copiado mal algún código. Es lo que tiene la edad.
    

Desconectado maxworld

  • Newbie
  • *
  • Mensajes: 29
    • Ver Perfil
  • Estación: ESAND2300000023320B
Re:He perdido la precipitación de ayer
« Respuesta #3 en: 24 de Mayo del 2021, 14:08:03 pm »
Me autocito. Me acabo de encontrar la plantilla configurada en UTC :o , juro que yo no la he tocado. La he cambiado a Civil. ¿Hay que hacer algo mas en la estación?

Puede que haya sido error por mi parte. Si es así pido disculpas. He tenido que adaptar un montón de estaciónes y es posible que haya copiado mal algún código. Es lo que tiene la edad.

Creo que tienes que hacer algo más. Al cambiar a Horario civil ahora no me actualiza, con el mismo mensaje que la otra vez
24-05-2021 09:45 UTC: No actualizada
No se ha detectado ningún cambio entre las dos últimas actualizaciones o bien el reloj está retrasado más de media hora. Comprueba que la zona horaria sea correcta.

Desconectado alvaror

  • Newbie
  • *
  • Mensajes: 9
    • Ver Perfil
  • Estación: Chiloeches - El Clavín - ESCLM1900000019163A
Re:He perdido la precipitación de ayer
« Respuesta #4 en: 24 de Mayo del 2021, 16:18:18 pm »
Hola!

Yo tengo un problemilla con la precipitación de ayer parecido al de maxworld. A las 22 UTC debería haberse puesto a 0, pero en vez de eso bajó de 9.4 a 2.5 mm. Luego a las 00 UTC ya sí que se puso a 0 y al acumulado mensual y anual se han sumado 2.5. Solamente hubo una tormenta en todo el día, algo antes de las 19 UTC, o sea que esos 2.5 no sé de dónde salieron.

Aunque la estación tiene unos meses, la semana pasada tuve que volver a configurar la estación porque tuve que reinstalar la app del móvil.
Como al mirar las instrucciones http://www.atmos.cat/perl?num=1578942090 vi que las has actualizado y me pareció interesante, ahora tengo la estación en horario civil y la página de meteoclimatic en UTC (antes las 2 en civil). El primer día con lluvia fue ayer, o sea que no sé si fue el momento concreto u otra cosa.

Como he revisado la configuración y no me sale nada raro he venido por aquí... y bueno, no sé si será por lo mismo o algo que no encuentro.

Desconectado casacota

  • Moderador Global
  • Hero Member
  • *****
  • Mensajes: 1.041
    • Ver Perfil
    • Observatori de Sant Martí de Canals
  • Estación: Sant Martí de Canals ESCAT2500000025518A
Re:He perdido la precipitación de ayer
« Respuesta #5 en: 24 de Mayo del 2021, 16:28:06 pm »
Creo que tienes que hacer algo más. Al cambiar a Horario civil ahora no me actualiza, con el mismo mensaje que la otra vez
24-05-2021 09:45 UTC: No actualizada
No se ha detectado ningún cambio entre las dos últimas actualizaciones o bien el reloj está retrasado más de media hora. Comprueba que la zona horaria sea correcta.

Efectivamente, tiene que ser en horario UTC, que es como se genera la plantilla. ESAND2300000023320B

En "path" tienes puesto /wu? supongo
    

Desconectado casacota

  • Moderador Global
  • Hero Member
  • *****
  • Mensajes: 1.041
    • Ver Perfil
    • Observatori de Sant Martí de Canals
  • Estación: Sant Martí de Canals ESCAT2500000025518A
Re:He perdido la precipitación de ayer
« Respuesta #6 en: 24 de Mayo del 2021, 16:37:18 pm »
Hola!

Yo tengo un problemilla con la precipitación de ayer parecido al de maxworld. A las 22 UTC debería haberse puesto a 0, pero en vez de eso bajó de 9.4 a 2.5 mm. Luego a las 00 UTC ya sí que se puso a 0 y al acumulado mensual y anual se han sumado 2.5. Solamente hubo una tormenta en todo el día, algo antes de las 19 UTC, o sea que esos 2.5 no sé de dónde salieron.

Aunque la estación tiene unos meses, la semana pasada tuve que volver a configurar la estación porque tuve que reinstalar la app del móvil.
Como al mirar las instrucciones http://www.atmos.cat/perl?num=1578942090 vi que las has actualizado y me pareció interesante, ahora tengo la estación en horario civil y la página de meteoclimatic en UTC (antes las 2 en civil). El primer día con lluvia fue ayer, o sea que no sé si fue el momento concreto u otra cosa.

Como he revisado la configuración y no me sale nada raro he venido por aquí... y bueno, no sé si será por lo mismo o algo que no encuentro.

Si has reconfigurado la estación es posible que no funcione correctamente hasta pasado un tiempo. De todos modos aquí: http://meteoclimatic.atmos.cat/pluja?codi=ESCLM1900000019163A puedes editar la lluvia de ayer y el total mensual y anual se arreglarán. Asimismo lo podrás añadir aquí https://www.meteoclimatic.net/index/pg.0.dades.html?station_id=ESCLM1900000019163A para que no haya inconsistencias.
Es algo complicado porque atmos.cat no está integrado en Meteoclimatic. Esperemos que algún día lo esté y se pueda manejar todo de modo centralizado.
    

Desconectado maxworld

  • Newbie
  • *
  • Mensajes: 29
    • Ver Perfil
  • Estación: ESAND2300000023320B
Re:He perdido la precipitación de ayer
« Respuesta #7 en: 24 de Mayo del 2021, 17:47:05 pm »
Creo que tienes que hacer algo más. Al cambiar a Horario civil ahora no me actualiza, con el mismo mensaje que la otra vez
24-05-2021 09:45 UTC: No actualizada
No se ha detectado ningún cambio entre las dos últimas actualizaciones o bien el reloj está retrasado más de media hora. Comprueba que la zona horaria sea correcta.

Efectivamente, tiene que ser en horario UTC, que es como se genera la plantilla. ESAND2300000023320B

En "path" tienes puesto /wu? supongo

casacota, no he tocado nada de nada en la estación. Yo la configuré hace meses en horario civil siguiendo vuestras instrucciones, añadiendo HC después de la clave y ya está. Luego un día  hubo un problema y me comentaste que habías hecho unos cambios y lo solucionaste . Y desde ayer me di cuenta que la plantilla volvía a UTC, la he puesto en HC y vuelve el error. Pero en la consola no he hecho cambios
Con el Path /wu a que te refieres? donde se pone eso?

Gracias
Un saludo

Desconectado maxworld

  • Newbie
  • *
  • Mensajes: 29
    • Ver Perfil
  • Estación: ESAND2300000023320B
Re:He perdido la precipitación de ayer
« Respuesta #8 en: 24 de Mayo del 2021, 18:18:49 pm »
Me acabo de dar cuenta de que habéis modificado las instrucciones para las Bresser!, pone esto "La zona horaria en Meteoclimatic tiene que ser UTC"  *-*

http://www.atmos.cat/perl?num=1583785855

¿Entonces vuelvo a configurar en UTC la plantilla de meteoclimatic? ¿y cómo soluciono entonces el tema de la preci ? A ver si es por que sigue poniendo HC después de la password


Desconectado casacota

  • Moderador Global
  • Hero Member
  • *****
  • Mensajes: 1.041
    • Ver Perfil
    • Observatori de Sant Martí de Canals
  • Estación: Sant Martí de Canals ESCAT2500000025518A
Re:He perdido la precipitación de ayer
« Respuesta #9 en: 24 de Mayo del 2021, 19:03:27 pm »
Me acabo de dar cuenta de que habéis modificado las instrucciones para las Bresser!, pone esto "La zona horaria en Meteoclimatic tiene que ser UTC"  *-*

http://www.atmos.cat/perl?num=1583785855

¿Entonces vuelvo a configurar en UTC la plantilla de meteoclimatic? ¿y cómo soluciono entonces el tema de la preci ? A ver si es por que sigue poniendo HC después de la password

Sí, tiene que estar en UTC. Diría que ya te lo cambié en su momento. Las instrucciones están modificadas para las nuevas, para el resto lo expliqué (creo) en el foro.
Lo que en mi servidor no se ve directamente si es una Bresses o una FO, por eso pregunté lo del "path", en las Bresser eso no interviene, olvídalo.
Que haya HC o no es indiferente a estas alturas. Lo de la precipitación será cuestión de seguirlo, pero lo puedes corregir como escrito más arriba.
    

Desconectado casacota

  • Moderador Global
  • Hero Member
  • *****
  • Mensajes: 1.041
    • Ver Perfil
    • Observatori de Sant Martí de Canals
  • Estación: Sant Martí de Canals ESCAT2500000025518A
Re:He perdido la precipitación de ayer
« Respuesta #10 en: 24 de Mayo del 2021, 22:46:14 pm »
Bien, ya veo el origen del problema con la lluvia. Las bresser en general mandan los datos cada 16 segundos, pero al parecer algunas lo hacen sólo cada 5 minutos. Ya sé que parece que no tenga nada que ver, pero sí que lo tiene, justo después de medianoche la API espera datos para hacer un reset, y si no llegan a tiempo se hace un lío. Ahora mismo me pongo a hacer un parche para que no ocurra más.
    

Desconectado maxworld

  • Newbie
  • *
  • Mensajes: 29
    • Ver Perfil
  • Estación: ESAND2300000023320B
Re:He perdido la precipitación de ayer
« Respuesta #11 en: 24 de Mayo del 2021, 22:56:20 pm »
Bien, ya veo el origen del problema con la lluvia. Las bresser en general mandan los datos cada 16 segundos, pero al parecer algunas lo hacen sólo cada 5 minutos. Ya sé que parece que no tenga nada que ver, pero sí que lo tiene, justo después de medianoche la API espera datos para hacer un reset, y si no llegan a tiempo se hace un lío. Ahora mismo me pongo a hacer un parche para que no ocurra más.
Eres un crack.  apla3

Desconectado maxworld

  • Newbie
  • *
  • Mensajes: 29
    • Ver Perfil
  • Estación: ESAND2300000023320B
Re:He perdido la precipitación de ayer
« Respuesta #12 en: 24 de Mayo del 2021, 23:17:09 pm »
En meteoclimatic puedo cambiar los datos diarios sin problema pero en atmos.cat no me deja cambiar los datos diarios y por tanto el mensual no se corrije, al pulsar guardar no hace nada, pongo el codigo de la estacion que supongo es  ESAND2300000023320B   

 .http://meteoclimatic.atmos.cat/pluja?codi=ESAND2300000023320B

Desconectado alvaror

  • Newbie
  • *
  • Mensajes: 9
    • Ver Perfil
  • Estación: Chiloeches - El Clavín - ESCLM1900000019163A
Re:He perdido la precipitación de ayer
« Respuesta #13 en: 25 de Mayo del 2021, 00:39:54 am »
Hola!

Yo tengo un problemilla con la precipitación de ayer parecido al de maxworld. A las 22 UTC debería haberse puesto a 0, pero en vez de eso bajó de 9.4 a 2.5 mm. Luego a las 00 UTC ya sí que se puso a 0 y al acumulado mensual y anual se han sumado 2.5. Solamente hubo una tormenta en todo el día, algo antes de las 19 UTC, o sea que esos 2.5 no sé de dónde salieron.

Aunque la estación tiene unos meses, la semana pasada tuve que volver a configurar la estación porque tuve que reinstalar la app del móvil.
Como al mirar las instrucciones http://www.atmos.cat/perl?num=1578942090 vi que las has actualizado y me pareció interesante, ahora tengo la estación en horario civil y la página de meteoclimatic en UTC (antes las 2 en civil). El primer día con lluvia fue ayer, o sea que no sé si fue el momento concreto u otra cosa.

Como he revisado la configuración y no me sale nada raro he venido por aquí... y bueno, no sé si será por lo mismo o algo que no encuentro.

Si has reconfigurado la estación es posible que no funcione correctamente hasta pasado un tiempo. De todos modos aquí: http://meteoclimatic.atmos.cat/pluja?codi=ESCLM1900000019163A puedes editar la lluvia de ayer y el total mensual y anual se arreglarán. Asimismo lo podrás añadir aquí https://www.meteoclimatic.net/index/pg.0.dades.html?station_id=ESCLM1900000019163A para que no haya inconsistencias.
Es algo complicado porque atmos.cat no está integrado en Meteoclimatic. Esperemos que algún día lo esté y se pueda manejar todo de modo centralizado.

Gracias casacota! Vale, a ver si se estabiliza con el tiempo y no pasa más. Muchas gracias por atmos.cat  :)

En meteoclimatic puedo cambiar los datos diarios sin problema pero en atmos.cat no me deja cambiar los datos diarios y por tanto el mensual no se corrije, al pulsar guardar no hace nada, pongo el codigo de la estacion que supongo es  ESAND2300000023320B   

 .http://meteoclimatic.atmos.cat/pluja?codi=ESAND2300000023320B

Yo he probado y tampoco... Hace como un mes corregí un día y no tuve problema, pero ahora no me deja.
Al cambiar el dato y dar a guardar vuelve al dato anterior. Aparece el mensaje "Estació sense codi. Només veure la precipitació diària del mes actual" a pesar de poner el código de meteoclimatic y la contraseña de atmos con la que activé la estación en su día.

Desconectado casacota

  • Moderador Global
  • Hero Member
  • *****
  • Mensajes: 1.041
    • Ver Perfil
    • Observatori de Sant Martí de Canals
  • Estación: Sant Martí de Canals ESCAT2500000025518A
Re:He perdido la precipitación de ayer
« Respuesta #14 en: 25 de Mayo del 2021, 00:44:33 am »
Ya veo... en el recuadro en blanco hay que poner el "station password", dar en guardar, y entonces sí que deja.

Como es el mismo script para diversos modelos y marcas, puede prestar a confusión. Miraré como arreglarlo.