Autor Tema: Weewx dejó de funcionar  (Leído 1623 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado ishffe

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
  • Estación: Huertas del Río - Archidona (ESAND2900000029314A)
Weewx dejó de funcionar
« en: 27 de Julio del 2021, 20:10:53 pm »
Buenas tardes a todos,

el día 24/07 fue el famoso apagón que dejó a media España sin luz. Pues bien, a mi me tocó ser de los que no tuvimos durante X tiempo. Todo funcionaba de maravilla pero desde ese día mi estación ha dejado de subir datos a Weewx (y en consecuencia a Meteoclimatic etc etc). He estado probando desde entonces mil cosas sin éxito. He vuelto a hacer una instalación limpia con la instalación automatica Meteowee (incluida nueva SSD) pero nada, no hay manera. Aquí os pongo lo que aparece en el log de Weewx cada 60 segundos para ver si alguien puede decirme cual es el problema. Lo agradezco enormemente de antemano.

Saludos. Isidro.


Jul 27 20:05:38 raspberrypi weewx[1394] INFO __main__: retrying...
Jul 27 20:05:38 raspberrypi weewx[1394] INFO __main__: Using configuration file /etc/weewx/weewx.conf
Jul 27 20:05:38 raspberrypi weewx[1394] INFO __main__: Debug is 0
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.engine: Loading station type WMR300 (weewx.drivers.wmr300)
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: driver version is 0.33
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: usb info: pyusb_version=1.0.2
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: sensor map is {'pressure': 'pressure', 'barometer': 'barometer', 'windSpeed': 'wind_avg', 'windDir': 'wind_dir', 'windGust': 'wind_gust', 'windGustDir': 'wind_gust_dir', 'inTemp': 'temperature_0', 'outTemp': 'temperature_1', 'extraTemp1': 'temperature_2', 'extraTemp2': 'temperature_3', 'extraTemp3': 'temperature_4', 'extraTemp4': 'temperature_5', 'extraTemp5': 'temperature_6', 'extraTemp6': 'temperature_7', 'extraTemp7': 'temperature_8', 'inHumidity': 'humidity_0', 'outHumidity': 'humidity_1', 'extraHumid1': 'humidity_2', 'extraHumid2': 'humidity_3', 'extraHumid3': 'humidity_4', 'extraHumid4': 'humidity_5', 'extraHumid5': 'humidity_6', 'extraHumid6': 'humidity_7', 'extraHumid7': 'humidity_8', 'dewpoint': 'dewpoint_1', 'extraDewpoint1': 'dewpoint_2', 'extraDewpoint2': 'dewpoint_3', 'extraDewpoint3': 'dewpoint_4', 'extraDewpoint4': 'dewpoint_5', 'extraDewpoint5': 'dewpoint_6', 'extraDewpoint6': 'dewpoint_7', 'extraDewpoint7': 'dewpoint_8', 'heatindex': 'heatindex_1', 'extraHeatindex1': 'heatindex_2', 'extraHeatindex2': 'heatindex_3', 'extraHeatindex3': 'heatindex_4', 'extraHeatindex4': 'heatindex_5', 'extraHeatindex5': 'heatindex_6', 'extraHeatindex6': 'heatindex_7', 'extraHeatindex7': 'heatindex_8', 'windchill': 'windchill', 'rainRate': 'rain_rate'}
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: history limit is 10% at index 3302
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: history index: 3873
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: communication established: {'packet_type': 87, 'station_type': 'WMR300', 'station_model': 'A004', 'magic0': 255, 'magic1': 255, 'history_cleared': False, 'mystery0': 73, 'mystery1': 44, 'history_end_index': 3873}
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.engine: StdConvert target unit is 0x1
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.engine: Archive will use data binding wx_binding
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.engine: Record generation will be attempted in 'hardware'
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.engine: Using archive interval of 300 seconds (specified in weewx configuration)
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.restx: StationRegistry: Registration not requested.
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.restx: Wunderground: Posting not enabled.
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.restx: PWSweather: Posting not enabled.
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.restx: CWOP: Posting not enabled.
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.restx: WOW: Posting not enabled.
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.restx: AWEKAS: Posting not enabled.
Jul 27 20:05:38 raspberrypi weewx[1394] INFO __main__: Starting up weewx version 4.5.1
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.engine: Using binding 'wx_binding' to database 'weewx.sdb'
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.manager: Starting backfill of daily summaries
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.manager: Daily summaries up to date
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: Reading records since 2021-07-24 02:56:00 CEST (1627088160) (last_index=31 history_end_index=3873)
Jul 27 20:05:38 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: init history attempt 1 of 5
Jul 27 20:05:39 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: init history cmd=0x65 rec=32
Jul 27 20:05:39 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: init history completed after attempt 1 of 5
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd4
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd5
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd3
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd3
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd3
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd3
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd3
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd3
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd3
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd3
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd3
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd6
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xdb
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xdc
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xdc
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xdc
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xdc
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xdc
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xdc
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xdc
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xdc
Jul 27 20:05:40 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xdc
Jul 27 20:05:41 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd4
Jul 27 20:05:41 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd5
Jul 27 20:05:41 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xd3
Jul 27 20:05:41 raspberrypi weewx[1394] INFO weewx.drivers.wmr300: ignored packet type 0xdc
Jul 27 20:05:42 raspberrypi weewx[1394] INFO weewx.engine: Main loop exiting. Shutting engine down.
Jul 27 20:05:42 raspberrypi weewx[1394] CRITICAL __main__: Caught WeeWxIOError: History record unexpected length: assumed 128, found 0
Jul 27 20:05:42 raspberrypi weewx[1394] CRITICAL __main__:     ****  Waiting 60 seconds then retrying...

Desconectado jantoni

  • Hero Member
  • *****
  • Mensajes: 3.725
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Weewx dejó de funcionar
« Respuesta #1 en: 28 de Julio del 2021, 08:43:51 am »
Pues así, de un vistazo rápido, porque no puedo estar mucho tiempo por aquí, parece un problema de lectura del datalogger.

Puede ser que la memoria del mismo esté corrupta.

Probaría borrando el datalogger, aunque perderías datos, evidentemente

Desconectado ishffe

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
  • Estación: Huertas del Río - Archidona (ESAND2900000029314A)
Re:Weewx dejó de funcionar
« Respuesta #2 en: 28 de Julio del 2021, 20:06:12 pm »
Buenas tardes,

pues efectivamente tenía que ser algo de eso ya que al resetear la consola de la estación se ha solucionado, pero la tarjeta SD antigua se ha corrompido y he perdido los más de dos años de datos que tenía en Weewx, menos mal que en meteoclimatic si que están. Muchas gracias por todo. Saludos.

Desconectado jantoni

  • Hero Member
  • *****
  • Mensajes: 3.725
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Weewx dejó de funcionar
« Respuesta #3 en: 28 de Julio del 2021, 21:10:14 pm »
Por eso siempre hay que tener una estrategia de copia de seguridad. Al menos de la base de datos

Desconectado edlmeteo

  • Full Member
  • ***
  • Mensajes: 108
    • Ver Perfil
  • Estación: Esparragosa de Lares (BA)- ESEXT0600000006620A Herrera del Duqe (BA)- ESEXT0600000006670A
Re:Weewx dejó de funcionar
« Respuesta #4 en: 06 de Septiembre del 2021, 10:50:24 am »
Aprovecho el hilo para comentar lo que me sucede. Desde hace un tiempo obtengo el log que adjunto en la imagen. Da un error de driver pero sospecho que puede ser porque la ISS no tiene batería y faltan datos en la trama de información que se envía a la consola. ¿Alguna sugerencia?

Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.403
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:Weewx dejó de funcionar
« Respuesta #5 en: 06 de Septiembre del 2021, 11:30:27 am »
Aprovecho el hilo para comentar lo que me sucede. Desde hace un tiempo obtengo el log que adjunto en la imagen. Da un error de driver pero sospecho que puede ser porque la ISS no tiene batería y faltan datos en la trama de información que se envía a la consola. ¿Alguna sugerencia?

Evidentemente el driver te notifica de que está recibiendo 0 caracteres, o sea que no le llegan datos de la consola. ISS sin batería ?? No le puedes poner una pila ??


Archena, Valle de Ricote (Murcia). 120 msnm. 19.622 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es

Desconectado jantoni

  • Hero Member
  • *****
  • Mensajes: 3.725
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Weewx dejó de funcionar
« Respuesta #6 en: 07 de Septiembre del 2021, 22:34:26 pm »
Así he estado yo un par de años, hasta que pude hacer una reparación.

El súper condensador estaba fastidiado y la pila se agotaba en nada.

A las 4 de la mañana se quedaba sin carga y ocurría lo que a ti.

Sustituí el súper condensador por otro comprado pero de una capacidad superior.

Por ahí debe estar el hilo en el que lo explicaba

Desconectado jantoni

  • Hero Member
  • *****
  • Mensajes: 3.725
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Weewx dejó de funcionar
« Respuesta #7 en: 08 de Septiembre del 2021, 00:30:07 am »
https://forum.meteoclimatic.net/index.php/topic,3417.0.html

Ah….parece que esta solución solo funciona en unidades de las más antiguas.

Davis, ha debido asegurarse que paséis por caja para comprar el repuesto…..que es casi toda la Iss, vergonzoso

Desconectado edlmeteo

  • Full Member
  • ***
  • Mensajes: 108
    • Ver Perfil
  • Estación: Esparragosa de Lares (BA)- ESEXT0600000006620A Herrera del Duqe (BA)- ESEXT0600000006670A
Re:Weewx dejó de funcionar
« Respuesta #8 en: 09 de Septiembre del 2021, 08:40:52 am »
Uff gracias por la respuesta... Puede que sea algo asi lo que me pase.