Autor Tema: Problema invocando script meteowee  (Leído 442 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado garbatella

  • Jr. Member
  • **
  • Mensajes: 52
    • Ver Perfil
  • Estación: ESCTB3900000039003A
Problema invocando script meteowee
« en: 27 de Diciembre del 2021, 09:58:17 am »
Tras estar funcionando semanas con la raspberry y todo montado, esta petó. No sé si sería como dicen algo relacionado con la tarjeta SD, pero el caso es que no arrancaba...

Así que de nuevo a instalar todo. Y en esas me veo ahora, que cuando he ido a invocar el script de jantoni, me da un error rarísimo:

Código: [Seleccionar]
pi@raspberrypi:~ $ sudo bash /home/pi/meteowee-0.16-2
/home/pi/meteowee-0.16-2: line 327: syntax error near unexpected token `('
/home/pi/meteowee-0.16-2: line 327: `sed -i 's/week       = %X (%A)/week       = %H:%M on %A/g' "$CONFIG_FILE"'

He editado el fichero y para mi no tiene sentido quitar los paréntesis que parece que generan el problema. Pero igualmente lo he hecho, guardado y salta con otro error...

No sé, es algo raro. He flasheado de nuevo la imagen en la SD, vuelto a copiar los ficheros, accedo por SSH, invoco meteowee y de nuevo el error. ¿Alguna idea?

Desconectado garbatella

  • Jr. Member
  • **
  • Mensajes: 52
    • Ver Perfil
  • Estación: ESCTB3900000039003A
Re:Problema invocando script meteowee
« Respuesta #1 en: 10 de Enero del 2022, 10:51:05 am »
BUenas de nuevo. A ver si alguien puede echarme una mano, no soy capaz de que esto eche a andar!

He tratado de escribir a @jantoni pero tiene los mensajes privados bloqueados  :-[

Desconectado garbatella

  • Jr. Member
  • **
  • Mensajes: 52
    • Ver Perfil
  • Estación: ESCTB3900000039003A
Re:Problema invocando script meteowee
« Respuesta #2 en: 10 de Enero del 2022, 11:19:57 am »
Tema resuelto... Madre mía que razón tiene jantoni cuando dice que "extraigamos correctamente la SD". Desde Mac, aunque lo hiciese con todas las precauciones, problemas. He tenido que montar una máquina virtual con windows para expulsar correctamente, y entonces y sólo entonces, el meteowee funciona finalmente...

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.535
    • Ver Perfil
    • Rivas-Vaciamadrid Centro
  • Estación: ESMAD2800000028522A
Re:Problema invocando script meteowee
« Respuesta #3 en: 11 de Enero del 2022, 20:38:14 pm »
 apla3

Si, parece una tontería, pero tanto en Windows como en Linux hay que extraer la tarjeta correctamente. Y en Mac que, en el fondo, es un Linux bonito, pues tiene que ser igual.

Me alegro que todo haya acabado bien.
Las opiniones que pueda escribir no suponen asesoramiento profesional. Cada usuario tomará sus decisiones bajo su propio riesgo.