Autor Tema: Weewx se para ¿sin motivo?  (Leído 1171 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado miguelru

  • Sr. Member
  • ****
  • Mensajes: 262
    • Ver Perfil
    • MeteoGodella
  • Estación: ESPVA4600000046110A ESCLM1600000016214A
Weewx se para ¿sin motivo?
« en: 08 de Septiembre del 2022, 23:30:49 pm »
Pues eso. Tengo una de las estaciones con Weewx 4.5.1 funcionando unos meses sin problemas, pero últimamente  hace las cuando Weewx realiza las tareas rutinarias cada 5 minutos (meter nuevos datos en BBDD, generar archivos web, etc. La última tarea es enviar por FTP archivos al server del hosting) y cuando le parece después de esa última tarea, aleatoriamente se para, si conecto a la RPi con Bitvise SSH dice conecta pero no se abren las ventanas de SFTP ni la consola "terminal console" por lo que no puedo hacer mas que desconectar la RPi y volver a conectarla.
e
Entonces vuelve a funcionar todo correctamente hasta que le parece que vuelve a pararse. Mirando logs de Weewx no se aprecia ningún error. Lo único que vi eran mensajes de "low voltage" en el "syslog". Cambie la fuente y han desaparecido estos mensajes, pero se sigue parando cuando le parece.

Le ha pasado a alguien o alguna idea?

Últimamente también he observado fallos en la adquisición de la imagen de una de las webcams. He deshabilitado esta desde crontab y la tengo en observación.

Desconectado jantoni

  • Hero Member
  • *****
  • Mensajes: 3.725
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Weewx se para ¿sin motivo?
« Respuesta #1 en: 08 de Septiembre del 2022, 23:57:14 pm »
Yo reporté este tipo de fallos aquí, en Meteoclimatic, hace años.

El problema venía de la fuente de alimentación o del cable ethernet, ya no recuerdo.

Seguro que el hilo anda por ahí, agazapado.

Supongo que la fuente de alimentación está conectada directamente a la Raspi y no a un hub. Si no es así, haz que la Raspi se aliemente de la fuente y no del hub. Aunque yo he tenido un hub alimentando a una raspi zero, una raspi normal y varias consolas sin problema. Pero cada fuente es un mundo y cada hub también

Desconectado miguelru

  • Sr. Member
  • ****
  • Mensajes: 262
    • Ver Perfil
    • MeteoGodella
  • Estación: ESPVA4600000046110A ESCLM1600000016214A
Re:Weewx se para ¿sin motivo?
« Respuesta #2 en: 09 de Septiembre del 2022, 00:41:23 am »
Hola.

No, esta directamente de fuente, china pero fuente de 5V 3A. Ya tuve problemas con fuentes en el pasado también, paros de la RPi y corrupción de tarjetas SD. Pero Ahora solo se para Weewx ¿?. He cambiado la fuente por otra también de 5V 3Amp.

He pedido una fuente original Raspberry por si acaso, aunque cuesta algo encontrarlas. Ahora casi todas son USB "C" para RPi 4

Comentaré como queda el tema.

Desconectado jantoni

  • Hero Member
  • *****
  • Mensajes: 3.725
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Weewx se para ¿sin motivo?
« Respuesta #3 en: 09 de Septiembre del 2022, 12:48:58 pm »
Ah, no, claro....si se para Weewx no es lo mismo que se quede la Raspi "sorda", que es lo que me pasaba a mi. Pero me dejé llevar por lo que dices de que tampoco responde a una conexión SSH.

Pues tenemos que acudir al log, que todo lo dice.

Siempre que no esté en RAM, que se borra al reiniciar, podemos ver que dice el log en el momento de pararse.

Te recomendaría que, hasta que demos con el problema, conectes la Raspi por HDMI a un monitor o televisor y le conectes un teclado a un puerto USB. De ese modo nos saltamos al SSH

Desconectado miguelru

  • Sr. Member
  • ****
  • Mensajes: 262
    • Ver Perfil
    • MeteoGodella
  • Estación: ESPVA4600000046110A ESCLM1600000016214A
Re:Weewx se para ¿sin motivo?
« Respuesta #4 en: 09 de Septiembre del 2022, 14:49:01 pm »
El problema es que ahora mismo estoy a muchos kilómetros de allí. Deje la RPi conectada a un enchufe con Sonoff y cuando se queda colgada apago y vuelvo a encender en remoto. Es un reboot a lo bruto hasta que vuelva.

Desconectado jantoni

  • Hero Member
  • *****
  • Mensajes: 3.725
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Weewx se para ¿sin motivo?
« Respuesta #5 en: 09 de Septiembre del 2022, 16:59:01 pm »
Veo que ambas estaciones son GW1001

Otra posibilidad es que el dispositivo Wifi entre en suspensión.

No sé que tipo de Raspi es. Si no es una 3 o 4, tendrás un pincho wifi (salvo que funcione con ethernet).

Una actualización del driver te ha podido dejar el dispositivo en suspensión al cabo de un tiempo de inactividad.

Pero es solo una conjetura, remota eso si.

Desconectado miguelru

  • Sr. Member
  • ****
  • Mensajes: 262
    • Ver Perfil
    • MeteoGodella
  • Estación: ESPVA4600000046110A ESCLM1600000016214A
Re:Weewx se para ¿sin motivo?
« Respuesta #6 en: 18 de Septiembre del 2022, 10:05:40 am »
Pues confirmo que el fallo era provocado por el comando de captura de imagen de una de las cámaras (o la cámara Dahua) que unas veces funciona y otras se queda colgado sin ver el streaming ffmpeg y provoca el paro de Weewx.