Autor Tema: Problema curioso en idioma skin bootstrap de Fuzzy-archer  (Leído 8014 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Xavi-EA5ZF

  • Full Member
  • ***
  • Mensajes: 212
  • Ham Radio Operator EA5ZF
    • Ver Perfil
    • MeteoLaVall
  • Estación: ESPVA1200000012600A
Problema curioso en idioma skin bootstrap de Fuzzy-archer
« en: 13 de Junio del 2017, 17:56:30 pm »
He encontrado mientras traducía mi web al valenciano/catalán un problema curioso que no acabo de entender.
El tema es que hay un parágrafo de etiquetas genéricas en las que si pongo un solo acento se deja de generar la parte que sea, bien en la zoa de relojes a la derecha si pongo los famosos acute/grave o en la derecha de las imágenes si pongo los acentos agudo o grave normales, la cuestión es que por una o por otra, pero no me deja poner acentos.
En cambio si personalizo la etiqueta dentro del skin.conf de la carpeta images si que deja poner acentos.
Es como si la parte que genera los relojes en el skin bootstrap o la que genera las imagenes del weewx normal estuviese forzada a ASCII estricto, no a UTF-8 y por ello dá error al compilar o generar las imágenes.

Citar
    [[Generic]]
        #
        # Generic labels, keyed by an observation type.
        #
        barometer      = Pressio barometrica
        dewpoint       = Punt de rosada
        heatindex      = Index de calor
        inHumidity     = Humitat interior
        outHumidity    = Humitat exterior
        inTemp         = Temperatura interior
        outTemp        = Temperatura exterior
        radiation      = Radiacio
        rain           = Precipitacio
        rainRate       = Taxa precipitacio
        windSpeed      = Velocitat vent
        windDir        = Direccio vent
        windGust       = Velocitat rafega
        windGustDir    = Sensacio termica
        windgustvec    = Vector rafega
        windvec        = Vector vent
« Última modificación: 13 de Junio del 2017, 20:14:25 pm por Xavi-EA5ZF »

Desconectado Xavi-EA5ZF

  • Full Member
  • ***
  • Mensajes: 212
  • Ham Radio Operator EA5ZF
    • Ver Perfil
    • MeteoLaVall
  • Estación: ESPVA1200000012600A
Re:Problema curioso en idioma skin bootstrap de Fuzzy-archer
« Respuesta #1 en: 13 de Junio del 2017, 19:38:15 pm »
El problema lo ubico en el skin.conf de la carpeta images, ya que si pongo idioma espanol acepta los acentos graves, pero si pongo catala, dá errores al poner los textos en las imágenes de los gráficos diarios, mensuales y anuales de la zona derecha.
Los relojes de la izquierda no dependen de este skin.conf, dependen del skin.conf de la carpeta del skin bootstrap, y si ahí se le pone catalá, si que traslada bien los acentos a los relojes de la izquierda.
Seguiré observando a ver si cazo el gazapo.

El error que dá es el siguiente:

Citar
Jun 13 17:45:37 localhost weewx[22082]: translategenerator.pyc: Language is catala
Jun 13 17:45:37 localhost weewx[22082]: reportengine: Caught unrecoverable exception in generator user.translategenerator.ImageGeneratorTranslated
Jun 13 17:45:37 localhost weewx[22082]:         ****  'utf8' codec can't decode byte 0xf3 in position 6: invalid continuation byte
Jun 13 17:45:37 localhost weewx[22082]:         ****  Traceback (most recent call last):
Jun 13 17:45:37 localhost weewx[22082]:         ****    File "/usr/share/weewx/weewx/reportengine.py", line 239, in run
Jun 13 17:45:37 localhost weewx[22082]:         ****      obj.start()
Jun 13 17:45:37 localhost weewx[22082]:         ****    File "/usr/share/weewx/weewx/reportengine.py", line 273, in start
Jun 13 17:45:37 localhost weewx[22082]:         ****      self.run()
Jun 13 17:45:37 localhost weewx[22082]:         ****    File "/usr/share/weewx/weewx/imagegenerator.py", line 31, in run
Jun 13 17:45:37 localhost weewx[22082]:         ****      self.genImages(self.gen_ts)
Jun 13 17:45:37 localhost weewx[22082]:         ****    File "/usr/share/weewx/weewx/imagegenerator.py", line 215, in genImages
Jun 13 17:45:37 localhost weewx[22082]:         ****      gap_fraction  = gap_fraction))
Jun 13 17:45:37 localhost weewx[22082]:         ****    File "/usr/share/weewx/weeplot/genplot.py", line 557, in __init__
Jun 13 17:45:37 localhost weewx[22082]:         ****      self.label       = to_unicode(label)
Jun 13 17:45:37 localhost weewx[22082]:         ****    File "/usr/share/weewx/weeutil/weeutil.py", line 1282, in to_unicode
Jun 13 17:45:37 localhost weewx[22082]:         ****      return unicode(string, encoding) if string is not None else None
Jun 13 17:45:37 localhost weewx[22082]:         ****    File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
Jun 13 17:45:37 localhost weewx[22082]:         ****      return codecs.utf_8_decode(input, errors, True)
Jun 13 17:45:37 localhost weewx[22082]:         ****  UnicodeDecodeError: 'utf8' codec can't decode byte 0xf3 in position 6: invalid continuation byte
Jun 13 17:45:37 localhost weewx[22082]:         ****  Generator terminated
« Última modificación: 13 de Junio del 2017, 20:19:00 pm por Xavi-EA5ZF »

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.653
    • Ver Perfil
    • Rivas-Vaciamadrid Centro
  • Estación: ESMAD2800000028522A
Re:Problema curioso en idioma skin bootstrap de Fuzzy-archer
« Respuesta #2 en: 14 de Junio del 2017, 08:57:20 am »
El gran lío de los idiomas en la informática.

Yo procuro evitar estos temas....siempre son problemáticas por la inmensa cantidad de codificaciones que existen.

Pero vamos al grano......

No conozco ese skin, pero deduzco de lo que dices y de lo que veo en el log, que se trata de un problema en los títulos de los gráficos (en este caso los relojes)

En su día, tuve el mismo problema con el skin standard, al poner los títulos y las leyendas en los gráficos. No le encontré solución y tampoco quise gastar tiempo en ello, se quedó sin acetos y sin eñes.

Suerte Xavi

73
Las opiniones que pueda escribir no suponen asesoramiento profesional. Cada usuario tomará sus decisiones bajo su propio riesgo.

Desconectado Xavi-EA5ZF

  • Full Member
  • ***
  • Mensajes: 212
  • Ham Radio Operator EA5ZF
    • Ver Perfil
    • MeteoLaVall
  • Estación: ESPVA1200000012600A
Re:Problema curioso en idioma skin bootstrap de Fuzzy-archer
« Respuesta #3 en: 14 de Junio del 2017, 09:20:02 am »
Efectivamente es el lío de los idiomas, al poner los acentos el problema no está en los relojes sino en los títulos de los gráficos de temperatura, humedad...
Lo realmente extraño es que en castellano si que me deja poner acentos y en valenciano no, ni tan siquiera si pongo sólo el acento agudo.
En otras partes de lal web, los acentos de cualquier tipo entran bien por via normal, bien por la forzada (&acute, &grave, &tilde, &cedil, &middot...) y aquí de ninguna forma.
De momento lo voy a dejar porque se me acaban los 3 días de vacaciones y vuelvo al ciclo de trabajo - estudio - cuidado de niños y mayores, por lo que dejo de tener tiempo para los hobbies.
Gracias.

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.653
    • Ver Perfil
    • Rivas-Vaciamadrid Centro
  • Estación: ESMAD2800000028522A
Re:Problema curioso en idioma skin bootstrap de Fuzzy-archer
« Respuesta #4 en: 14 de Junio del 2017, 10:36:44 am »
Pero lo que va en el cuerpo del código html no lo procesa el imagegenerator, sino que es embutido en la página, y el navegador web es el que lo interpreta.

Aquí el problema es el imagegenerator.

Se me ocurre alguna manera de arreglarlo, pero con el móvil no >:(
Las opiniones que pueda escribir no suponen asesoramiento profesional. Cada usuario tomará sus decisiones bajo su propio riesgo.

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.653
    • Ver Perfil
    • Rivas-Vaciamadrid Centro
  • Estación: ESMAD2800000028522A
Re:Problema curioso en idioma skin bootstrap de Fuzzy-archer
« Respuesta #5 en: 15 de Junio del 2017, 08:58:06 am »
Una posible solución es la siguiente.

En el script de inicio de weewx, es decir en /etc/init.d/weewx.con indicar el código de caracteres a utilizar

En mi tutorial de noviembre de 2015, para la instalación de weewx ya hacía referencia a los problemas con el lenguaje.

Es incorporar estas líneas, por ejemplo para castellano:

Citar
#Establece locales para que aparezcan las etiquetas de fecha y hora en castellano
export LANG="es_ES.UTF-8"
export LANGUAGE="es_ES.UTF-8"
export LC_ALL="es_ES.UTF-8"


Ahora bien, si el problema, es porque quieres tener varios idiomas, entonces ya no se me ocurre nada.

73
Las opiniones que pueda escribir no suponen asesoramiento profesional. Cada usuario tomará sus decisiones bajo su propio riesgo.

Desconectado Xavi-EA5ZF

  • Full Member
  • ***
  • Mensajes: 212
  • Ham Radio Operator EA5ZF
    • Ver Perfil
    • MeteoLaVall
  • Estación: ESPVA1200000012600A
Re:Problema curioso en idioma skin bootstrap de Fuzzy-archer
« Respuesta #6 en: 15 de Junio del 2017, 19:35:29 pm »
Citar
export LANG="ca_ES.UTF-8"
export LANGUAGE="ca_ES.UTF-8"
export LC_ALL="ca_ES.UTF-8"
Como verás, eso no era, lo de arriba es lo que tengo puesto desde hace un tiempo en el weewx.

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.653
    • Ver Perfil
    • Rivas-Vaciamadrid Centro
  • Estación: ESMAD2800000028522A
Re:Problema curioso en idioma skin bootstrap de Fuzzy-archer
« Respuesta #7 en: 24 de Junio del 2017, 16:11:57 pm »
Aquí, lo tienes.....recordaba que había problemas con ello, porque lo sufrí en mis carnes.....pero ahora está bien documentado

http://weewx.com/docs/devnotes.htm#Internationalization
Las opiniones que pueda escribir no suponen asesoramiento profesional. Cada usuario tomará sus decisiones bajo su propio riesgo.

Desconectado Xavi-EA5ZF

  • Full Member
  • ***
  • Mensajes: 212
  • Ham Radio Operator EA5ZF
    • Ver Perfil
    • MeteoLaVall
  • Estación: ESPVA1200000012600A
Re:Problema curioso en idioma skin bootstrap de Fuzzy-archer
« Respuesta #8 en: 24 de Junio del 2017, 18:50:53 pm »
Documentado, que no equivale a solucionado, precisamente mi problema está en el generador de imagenes, como comenté, los relojes, que se insertan como imagen sin texto y el texto se pone después van bien, pero los gráficos que llevan texto en los ejes incorporado dentro de ellos no.
Citar
Instead, weeWX mostly uses regular strings, with any non-ASCII characters encoded as UTF-8.

An exception to this general rule is the image generator, which holds labels internally in Unicode, because that is the encoding expected by most fonts.

De momento, pongo en modo manual los textos que fallan y ya sale todo por pantalla correctamente, acentos incluidos.

Gracias.
--... ...--
-.-. ..-

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.653
    • Ver Perfil
    • Rivas-Vaciamadrid Centro
  • Estación: ESMAD2800000028522A
Re:Problema curioso en idioma skin bootstrap de Fuzzy-archer
« Respuesta #9 en: 24 de Junio del 2017, 19:15:03 pm »
Efectivamente, cuando decía documentado, quería decir documentado *+* *+* *+* *+* *+*

Por lo menos, ves que es un problema general y no te vuelves loco buscando la solución.
Las opiniones que pueda escribir no suponen asesoramiento profesional. Cada usuario tomará sus decisiones bajo su propio riesgo.