Autor Tema: Weewx no recoge datos de velocidad y dirección del viento  (Leído 14112 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado juanantoniomosquera

  • Newbie
  • *
  • Mensajes: 25
  • MeteoMontaos
    • Ver Perfil
    • MeteoMontaos
  • Estación: Montaos
Re:Weewx no recoge datos de velocidad y dirección del viento
« Respuesta #15 en: 04 de Enero del 2019, 08:38:57 am »
Hola... tengo el mismo problema desde hace unos meses, posiblemente desde que actualizé a la versión 3.8.*.

www.meteomontaos.es

En el foro de Weewx user no me dan solución... he puesto modo debug para ver los paquetes que llegan de la estación y parece que los de viento llegan a cero, pero los de dirección sí llegan.

Lo que pasa que al no haber velocidad ignora los de dirección, para que esto no pase debes activar este flag

[StdWXCalculate]
   
ignore_zero_wind = False

    [[Calculations]]
        # Derived quantities are calculated by this service. Possible values are:
        #  hardware        - use the value provided by hardware
        #  software        - use the value calculated by weewx
        #  prefer_hardware - use value provide by hardware if available,
        #                      otherwise use value calculated by weewx
       
        pressure = prefer_hardware
        barometer = prefer_hardware
        altimeter = prefer_hardware
        windchill = prefer_hardware
        heatindex = prefer_hardware
        dewpoint = prefer_hardware
        inDewpoint = prefer_hardware
        rainRate = prefer_hardware

#############################################


Uso una Oregon WMR300, y en la consola si aparecen datos de viento, he probado a resetear con el botón de atrás pero nada. Me falta probar con el software de Oregon a ver qué pasa.

Si tenéis novedades avisad.

Saludos  y gracias.


El relevo del colaborador AEMET más anciano de Hispania.
http://www.meteomontaos.es
Oregon Scientific WMR300

Desconectado saba01

  • Newbie
  • *
  • Mensajes: 31
    • Ver Perfil
  • Estación: ESCAT1700000017800D
Re:Weewx no recoge datos de velocidad y dirección del viento
« Respuesta #16 en: 08 de Diciembre del 2019, 19:45:05 pm »
hola,

alguien lo ha podido solucionar?
a mi me passa desde que he puesto el anemómetro a parte con un transmisor,
en la consola llega todo bien pero weewx no coge los datos de velocidad y dirección del viento

Código: [Seleccionar]
trendIcon: 0, txBatteryStatus: 0, usUnits: 16, windchill: 5.33333333333, [b]windDir: None[/b], windGust: 0.0, windGustDir: None, [b]windSpeed: 0.0[/b], windSpeed10: 0.0

Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.403
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:Weewx no recoge datos de velocidad y dirección del viento
« Respuesta #17 en: 08 de Diciembre del 2019, 22:24:54 pm »
Hola

En el weewx.conf en la sección de configuración de la Davis hay unas líneas en las que pone esto:

# The id of your ISS station (usually 1). If you use a wind meter connected
    # to a anemometer transmitter kit, use its id
    iss_id = 1

Prueba a poner ahí el número del ISS que le tienes puesto al segundo anemo y reinicia weewx a ver.


Archena, Valle de Ricote (Murcia). 120 msnm. 19.622 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es

Desconectado saba01

  • Newbie
  • *
  • Mensajes: 31
    • Ver Perfil
  • Estación: ESCAT1700000017800D
Re:Weewx no recoge datos de velocidad y dirección del viento
« Respuesta #18 en: 09 de Diciembre del 2019, 07:25:19 am »
Gracias por responder tan pronto
Dejé el demonio ejecutado en una consola y sorpresa, esta mañana pilla bien los datos, llegan lecturas de datos de dirección y velocidad del viento.
He parado el weewxd y lo he vuelto a ejecutar y volvemos al windDir: None  :'(  tanto con iss_id= 1 como = 2.
Imagino que dejando un rato o unas horas volvería a pillar datos del viento como ha ocurrido esta noche.

Ya no entiendo nada, como quiero meterle una SSD al la Raspberry probaré en instalación limpia a ver como se comporta, tengo intención de hacerlo con Docker si encuentro una imagen actualizada. Alguien tiene alguna experiencia weewx+docker+datalogger IP oficial??
Para no perder datos tenia pensado copiar la base de datos de la instalación antigua a la nueva, es suficiente?

Por cierto, no tengo un segundo anemómetro, es el que había en la estación que lo he separado y le he puesto un transmisor. Lo he configurado en el ID 2.
La versión del weewx en la 3.9.2



Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.403
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:Weewx no recoge datos de velocidad y dirección del viento
« Respuesta #19 en: 09 de Diciembre del 2019, 11:13:38 am »
Pues todo un misterio eso del anemo...

Recuerda que debes de tener weewx como servicio ejecutándose y nunca simultáneamente con la utilidad weewxd, o uno u otro pero no los dos a la vez funcionando.

En cuanto a lo de la base de datos es suficiente con copiarla, lo que no tengo es ninguna experiencia con Docker.

Saludos


Archena, Valle de Ricote (Murcia). 120 msnm. 19.622 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es

Desconectado saba01

  • Newbie
  • *
  • Mensajes: 31
    • Ver Perfil
  • Estación: ESCAT1700000017800D
Re:Weewx no recoge datos de velocidad y dirección del viento
« Respuesta #20 en: 12 de Diciembre del 2019, 09:00:57 am »
Creo que encontré la explicación en el grupo de google, lo que creía que era un mal funcionamiento parece ser que es correcto  ???
si no hay viento no hay dirección del viento.

Sacado de aquí: https://groups.google.com/forum/#!topic/weewx-user/qGKvOqjU9LI
Citar
On Saturday, January 23, 2016 at 4:49:33 PM UTC-5, Domi S wrote:

  Hello wunderground gets no directiondata when the wind speed reaches 0km/h.
  Can i set somewhere that weewx don't delete this Winddirection values?
---------------------------------------------------------------------------------------------------------------------
as dave noted, this is by design - if there is no wind speed, the wind direction is undefined.

in weewx, this policy is enforced by the StdWXCalculate service.

if you prefer to report a wind direction when there is no wind speed (maybe your direction sensor is more sensitive than your speed sensor?  or maybe you just like to go against common logic :), then you can disable the policy like this in weewx.conf:

[StdWXCalculate]
    ignore_zero_wind = False

que os parece mejor, que indique N/A o que salga la ultima dirección recibida?