Autor Tema: Bloqueado II  (Leído 8283 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Telares

  • Hero Member
  • *****
  • Mensajes: 642
    • Ver Perfil
  • Estación: Matueca ESCYL2400000024820A
Bloqueado II
« en: 03 de Diciembre del 2019, 08:36:51 am »
Hola, desde ayer por la noche WeeWX parece parado. Me ocurre de vez en cuando y mi primera reacción es reiniciar. Ésto suele funcionar pero me quedo sin saber el motivo del fallo. En esta ocasión me he acordado de mirar antes:

root@raspberrypi:~# service weewx status
● weewx.service - LSB: weewx weather system
   Loaded: loaded (/etc/init.d/weewx)
   Active: active (running) since mié 2019-11-27 13:52:55 UTC; 5 days ago
  Process: 3566 ExecStop=/etc/init.d/weewx stop (code=exited, status=0/SUCCESS)
  Process: 3626 ExecStart=/etc/init.d/weewx start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/weewx.service
           └─3640 python /usr/bin/weewxd --daemon --pidfile=/var/run/weewx.pid /etc/weewx/weewx.conf

dic 03 07:23:40 raspberrypi weewx[3640]: fousb: unstable read: blocks differ for ptr 0x008fa0
dic 03 07:23:40 raspberrypi weewx[3640]: fousb: unstable read: blocks differ for ptr 0x008fa0
dic 03 07:26:04 raspberrypi weewx[3640]: fousb: unstable read: blocks differ for ptr 0x008fa0
dic 03 07:26:04 raspberrypi weewx[3640]: fousb: unstable read: blocks differ for ptr 0x008fa0
dic 03 07:26:52 raspberrypi weewx[3640]: fousb: unstable read: blocks differ for ptr 0x008fa0
dic 03 07:26:52 raspberrypi weewx[3640]: fousb: unstable read: blocks differ for ptr 0x008fa0
dic 03 07:27:40 raspberrypi weewx[3640]: fousb: unstable read: blocks differ for ptr 0x008fa0
dic 03 07:27:40 raspberrypi weewx[3640]: fousb: unstable read: blocks differ for ptr 0x008fa0
dic 03 07:30:04 raspberrypi weewx[3640]: fousb: unstable read: blocks differ for ptr 0x008fa0
dic 03 07:30:04 raspberrypi weewx[3640]: fousb: unstable read: blocks differ for ptr 0x008fa0


Alguien sabe a qué se debe? Gracias de antemano.
 

Desconectado Telares

  • Hero Member
  • *****
  • Mensajes: 642
    • Ver Perfil
  • Estación: Matueca ESCYL2400000024820A
Re:Bloqueado II
« Respuesta #1 en: 03 de Diciembre del 2019, 08:44:08 am »
He parado el programa, desconectado y vuelta a conectar el USB y ahora sale:

root@raspberrypi:~# service weewx status
● weewx.service - LSB: weewx weather system
   Loaded: loaded (/etc/init.d/weewx)
   Active: active (running) since mar 2019-12-03 07:40:54 UTC; 50s ago
  Process: 2919 ExecStop=/etc/init.d/weewx stop (code=exited, status=0/SUCCESS)
  Process: 2984 ExecStart=/etc/init.d/weewx start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/weewx.service
           └─2998 python /usr/bin/weewxd --daemon --pidfile=/var/run/weewx.pid /etc/weewx/weewx.conf

dic 03 07:40:55 raspberrypi weewx[2998]: engine: Using binding 'wx_binding' to database 'weewx.sdb'
dic 03 07:40:55 raspberrypi weewx[2998]: manager: Starting backfill of daily summaries
dic 03 07:40:56 raspberrypi weewx[2998]: restx: StationRegistry: Station will not be registered: no station_url specified.
dic 03 07:40:56 raspberrypi weewx[2998]: restx: Wunderground: Posting not enabled.
dic 03 07:40:56 raspberrypi weewx[2998]: restx: PWSweather: Posting not enabled.
dic 03 07:40:56 raspberrypi weewx[2998]: restx: CWOP: Posting not enabled.
dic 03 07:40:56 raspberrypi weewx[2998]: restx: WOW: Posting not enabled.
dic 03 07:40:56 raspberrypi weewx[2998]: restx: AWEKAS: Posting not enabled.
dic 03 07:40:56 raspberrypi weewx[2998]: engine: Starting up weewx version 3.7.1
dic 03 07:40:57 raspberrypi weewx[2998]: fousb: synchronising to the weather station (quality=1)

Desconectado Telares

  • Hero Member
  • *****
  • Mensajes: 642
    • Ver Perfil
  • Estación: Matueca ESCYL2400000024820A
Re:Bloqueado II
« Respuesta #2 en: 03 de Diciembre del 2019, 08:54:53 am »
Y ahora, después de darle tiempo a la raspi, ya actualiza. Qué pasó?

Desconectado Telares

  • Hero Member
  • *****
  • Mensajes: 642
    • Ver Perfil
  • Estación: Matueca ESCYL2400000024820A
Re:Bloqueado II
« Respuesta #3 en: 31 de Enero del 2020, 08:45:31 am »
Hola, vuelve a quedar bloqueado.

root@raspberrypi:~# service weewx status
● weewx.service - LSB: weewx weather system
   Loaded: loaded (/etc/init.d/weewx)
   Active: active (running) since dom 2020-01-12 08:26:03 UTC; 2 weeks 4 days ago
  Process: 23965 ExecStop=/etc/init.d/weewx stop (code=exited, status=0/SUCCESS)
  Process: 24025 ExecStart=/etc/init.d/weewx start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/weewx.service
           └─24045 python /usr/bin/weewxd --daemon --pidfile=/var/run/weewx.pid /etc/weewx/weewx.conf

ene 30 19:51:14 raspberrypi weewx[24045]: copygenerator: copied 0 files to /var/www/html/weewx
ene 30 19:55:00 raspberrypi weewx[24045]: fousb: unstable read: blocks differ for ptr 0x00b620
ene 30 19:55:00 raspberrypi weewx[24045]: fousb: unstable read: blocks differ for ptr 0x00b620
ene 30 19:55:00 raspberrypi weewx[24045]: fousb: station status {'unknown': 3, 'lost_connection': 0, 'rain_overflow': 0} (3)
ene 30 19:55:00 raspberrypi weewx[24045]: engine: 2020-01-30 19:55:01 UTC (1580414101) LOOP value 'pressure' 0.81798065375 outside limits...0, 34.5)
ene 30 19:55:00 raspberrypi weewx[24045]: engine: 2020-01-30 19:55:01 UTC (1580414101) LOOP value 'inHumidity' 126.0 outside limits (0.0, 100.0)
ene 30 19:55:00 raspberrypi weewx[24045]: engine: 2020-01-30 19:55:01 UTC (1580414101) LOOP value 'inTemp' 504.5 outside limits (10.0, 120.0)
ene 30 19:55:03 raspberrypi weewx[24045]: engine: 2020-01-30 19:55:04 UTC (1580414104) LOOP value 'pressure' 0.81798065375 outside limits...0, 34.5)
ene 30 19:55:03 raspberrypi weewx[24045]: engine: 2020-01-30 19:55:04 UTC (1580414104) LOOP value 'inHumidity' 126.0 outside limits (0.0, 100.0)
ene 30 19:55:03 raspberrypi weewx[24045]: engine: 2020-01-30 19:55:04 UTC (1580414104) LOOP value 'inTemp' 504.5 outside limits (10.0, 120.0)
Hint: Some lines were ellipsized, use -l to show in full.

Pone no sé qué de usb... será el cable que comunica con la consola. Las lucecitas de la raspi parecen funcionando correctamente.
Gracias.

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.618
    • Ver Perfil
    • Rivas-Vaciamadrid Centro
  • Estación: ESMAD2800000028522A
Re:Bloqueado II
« Respuesta #4 en: 31 de Enero del 2020, 10:01:46 am »
Parece un problema de comunicación entre el ordenador y la fineoffset.

Lo primero que debes probar es otro cable, que sea de calidad
Las opiniones que pueda escribir no suponen asesoramiento profesional. Cada usuario tomará sus decisiones bajo su propio riesgo.

Desconectado Telares

  • Hero Member
  • *****
  • Mensajes: 642
    • Ver Perfil
  • Estación: Matueca ESCYL2400000024820A
Re:Bloqueado II
« Respuesta #5 en: 31 de Enero del 2020, 12:37:03 pm »
Gracias Jantoni, en cuanto pueda lo busco.  Ahora tengo uno apantallado y con ferrita. La verdad es que no sé qué es "uno de calidad". Alguna sugerencia concreta?
Saludos.

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.618
    • Ver Perfil
    • Rivas-Vaciamadrid Centro
  • Estación: ESMAD2800000028522A
Re:Bloqueado II
« Respuesta #6 en: 31 de Enero del 2020, 13:48:57 pm »
Pues no, ese debería ser suficiente

Posiblemente, si con ese cable tienes problemas, deberías buscar la causa en una fuente externa.

Una fuente de alimentación chunga puede ser una fuente de conflictos importante. Uña asquerosidad de esas que venden para dar internet por la red eléctrica, llamados PLC, es una fuente de mierda que puede causar interferencias a casi cualquier cosa.

No obstante por probar un cable nuevo, pierdes poco.

Otras opciones , como el reinicio de la consola, me imagino que ya lo habrás probado, inclusive el borrado total de la memoria con la utilidad que puse hace años, bajada de la página de Ambiente Weather.
Las opiniones que pueda escribir no suponen asesoramiento profesional. Cada usuario tomará sus decisiones bajo su propio riesgo.

Desconectado Telares

  • Hero Member
  • *****
  • Mensajes: 642
    • Ver Perfil
  • Estación: Matueca ESCYL2400000024820A
Re:Bloqueado II
« Respuesta #7 en: 31 de Enero del 2020, 20:16:05 pm »
Reinicio de la consola, ya probé. El borrado ése, no, pero lo buscaré. Cambiaré el USB y la fuente de alimentación. Respecto a la asquerosidad, efectivamente es con ella con lo que conecto la raspi pero no sé si hay otra opción. Mi raspi, creo recordar que lleva mal lo de añadirle WiFi.
No sé si tiene importancia, pero en el momento del corte se produjeron dos mínimas anómalas procedentes del termohigro. Puede que sean causa del fallo o efecto colateral de él.
Gracias.

Desconectado Telares

  • Hero Member
  • *****
  • Mensajes: 642
    • Ver Perfil
  • Estación: Matueca ESCYL2400000024820A
Re:Bloqueado II
« Respuesta #8 en: 31 de Enero del 2020, 20:26:55 pm »
Ah! Parece entonces que ésto no tiene nada que ver con WeeWX. Éste no ha estado bloqueado en ningún momento. Y yo echándole la culpa al programa favorito de Jantoni...
Muévase el tema, si procede, al subforo adecuado.
Gracias.

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.618
    • Ver Perfil
    • Rivas-Vaciamadrid Centro
  • Estación: ESMAD2800000028522A
Re:Bloqueado II
« Respuesta #9 en: 31 de Enero del 2020, 20:45:34 pm »
Bueno, la fuente si es una Raspi2 es fácil, pues con una de un teléfono móvil es suficiente.

Para 3, no sé qué fuente hace falta. Para 4, hace falta Usb C con 3A., ya menos habitual en nuestro depósito de trastos.

El PLC hay que evitarlo, SIEMPRE.

El wifi con Raspi, lo que yo recuerdo era el problema del ahorro de energía con los adaptadores wifi usb. Deshabitando el ahorro de energía en los adaptadores se solucionaba el problema.

Habría que revisar Google un poco.

De hecho tuve una raspi con una raspicam clonica y estuvo mandando fotos sin problema día y noche desde el jardín.

Saludos
Las opiniones que pueda escribir no suponen asesoramiento profesional. Cada usuario tomará sus decisiones bajo su propio riesgo.

Desconectado Telares

  • Hero Member
  • *****
  • Mensajes: 642
    • Ver Perfil
  • Estación: Matueca ESCYL2400000024820A
Re:Bloqueado II
« Respuesta #10 en: 31 de Enero del 2020, 21:14:29 pm »
Creo que es la raspi 'básica" de 512M, supongo que la que llamas 2. Me toca entonces buscar cómo conectarla por WiFi. Deseadme suerte! Soy carpintero y saliendo de mi oficio....
Espero no darte, Jantoni, mucho la brasa.
Gracias

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.618
    • Ver Perfil
    • Rivas-Vaciamadrid Centro
  • Estación: ESMAD2800000028522A
Re:Bloqueado II
« Respuesta #11 en: 31 de Enero del 2020, 21:19:38 pm »
Yo tengo 3 raspis

La original, de 256 MB, modelo B, del 2012
La,siguiente B, de 512de ram, creo del 2013
La raspi2 que la tengo arrinconada unida a un proyector de cine.

Así que no debes tener mucho problema.

Yo hace mucho que no toco las raspis salvo para weewx, ja ja ja
Las opiniones que pueda escribir no suponen asesoramiento profesional. Cada usuario tomará sus decisiones bajo su propio riesgo.

Desconectado Audit

  • Moderador Global
  • Sr. Member
  • ******
  • Mensajes: 329
    • Ver Perfil
  • Estación: Auditorías
Re:Bloqueado II
« Respuesta #12 en: 31 de Enero del 2020, 21:40:02 pm »
A ver, tengamos la fiesta en paz. Llevo con los PLC al menos 10 años, con una PCE al principio y los últimos 5 con la Davis, y nunca he tenido problemas de ese tipo.
 
Eso sí, conectado por cable al ordenador, sin wifi.

Ahora mismo, la Davis está a unos 80 metros de distancia y con dos edificios por medio, y en ningún momento se ha producido nada raro. Todos los picos se han debido a cortes de luz, que por desgracia, hay temporadas que son demasiado frecuentes.

Desde hace unas semanas, tengo opertiva una cámara de forma provisional, y no llegaba la señal wifi, monté un receptor wifi PLC, y ahora tego dos viviendas conectadas a la misma red, pero con distribución en las dos viviendas con PLC. Hay unos 30 metros entre las dos viviendas, y entre el router y la cámara casi 45, en ningún momento he detectado cortes de señal ni interferencias de ningún tipo.

Así que, Jantoni, lo que tienes que hacer es comprar unos PLC en condiciones, que los pillarías en los chinos  y los tendrás griposos del todo.

Bromas a parte, imagino que dependerá mucho de la calidad de los equipos y sobre todo de la instalción eléctrica, posiblemente un mal PLC  en una instalación con problemas sea, un foco de dolores de cabeza.


Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 3.618
    • Ver Perfil
    • Rivas-Vaciamadrid Centro
  • Estación: ESMAD2800000028522A
Re:Bloqueado II
« Respuesta #13 en: 31 de Enero del 2020, 21:43:50 pm »
No, querido tocayo.

No compro un PLC ni harto de vino *+* *+* *+*

Son efectos colaterales de ser radioaficionado, que le vamos a hacer.
Las opiniones que pueda escribir no suponen asesoramiento profesional. Cada usuario tomará sus decisiones bajo su propio riesgo.

Desconectado jmviper

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.239
  • "Vortex Complex"
    • Ver Perfil
    • www.meteoarchena.es
  • Estación: Archena - ESMUR3000000030600B
Re:Bloqueado II
« Respuesta #14 en: 31 de Enero del 2020, 22:27:34 pm »
Yo también no soy muy partidario de los PLC... por lo menos los que pillé TP-LINK tienen unos microcortes muy molestos así que opté por volver al pincho wifi y muuuuchos menos dolores de cabeza.


Archena, Valle de Ricote (Murcia). 120 msnm. 19.500 hab.
Davis Vantage Pro2 Plus

www.meteoarchena.es