Autor Tema: No me actualiza  (Leído 4060 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado burgati

  • Full Member
  • ***
  • Mensajes: 196
    • Ver Perfil
  • Estación: "Burgos-Plaza san Agustín- ESCYL0900000009001D"
Re:No me actualiza
« Respuesta #15 en: 12 de Diciembre del 2016, 20:43:22 pm »
¿has configurado el envio?

He instalado weewx en la raspy, he cambiado plantilla por la de weewx poniendo el cod y el sig de la plantilla descargada de mi estacion y solo he hecho eso y no me actualiza,,,,,quiero decir hago la comprobacion con la ip del raspy/weewx/meteoclimatic.htm y no me lo actualiza


jantoni

  • Visitante
Re:No me actualiza
« Respuesta #16 en: 13 de Diciembre del 2016, 07:10:45 am »
Paso esto a weewx

Y pasa datos del log, luego a la noche lo veo

Desconectado burgati

  • Full Member
  • ***
  • Mensajes: 196
    • Ver Perfil
  • Estación: "Burgos-Plaza san Agustín- ESCYL0900000009001D"
Re:No me actualiza
« Respuesta #17 en: 13 de Diciembre del 2016, 14:11:58 pm »
Paso esto a weewx

Y pasa datos del log, luego a la noche lo veo

Ahi va archivo con logs

Si no podeís abrir archivo me decis que pongo pantallazos se abre con el word pad de windows asique igual no podéis
« Última modificación: 13 de Diciembre del 2016, 15:00:26 pm por burgati »

Desconectado zapal

  • Full Member
  • ***
  • Mensajes: 119
    • Ver Perfil
    • EL tiempo en los locos
  • Estación: torrevieja-los locos (ESPVA0300000003183A)
Re:No me actualiza
« Respuesta #18 en: 13 de Diciembre del 2016, 19:44:18 pm »
Prueba reiniciando la consola (quita las pilas). Ese log que has puesto indica algunos errores de valores de tiempos de lectura o toma de datos y diferente hora de consola y raspi. Repasa eso tambien. Ademas veo que se te para el weewx, no veo lectura de datos de consola-raspi, tan solo el generador de ficheros funcionando.

Un saludo

jantoni

  • Visitante
Re:No me actualiza
« Respuesta #19 en: 13 de Diciembre del 2016, 19:45:06 pm »
Mal

Dec 12 16:17:14 raspberrypi weewx[2086]: engine: The archive interval in the configuration file (900) does not match the station hardware interval (600).

jantoni

  • Visitante
Re:No me actualiza
« Respuesta #20 en: 13 de Diciembre del 2016, 19:45:35 pm »
Mal

Dec 12 16:17:14 raspberrypi weewx[2086]: engine: The archive interval in the configuration file (900) does not match the station hardware interval (600).

jantoni

  • Visitante
Re:No me actualiza
« Respuesta #21 en: 13 de Diciembre del 2016, 19:47:33 pm »
Hostia tu.....

Dec 12 16:17:17 raspberrypi weewx[2086]: manager: added record 2016-12-03 10:10:00 UTC (1480759800) to database '/var/lib/weewx/weewx.sdb'
Dec 12 16:17:18 raspberrypi weewx[2086]: manager: added record 2016-12-03 10:10:00 UTC (1480759800) to daily summary in

Le estás metiendo todo el datalogger.......ya me huelo lo que pasa.....espera que sigo avanzando

jantoni

  • Visitante
Re:No me actualiza
« Respuesta #22 en: 13 de Diciembre del 2016, 19:50:06 pm »
Dec 12 16:37:52 raspberrypi weewx[2086]: engine: Starting main packet loop


20 minutos después ha terminado de leer el datalogger.....ahora vienen los problemas

jantoni

  • Visitante
Re:No me actualiza
« Respuesta #23 en: 13 de Diciembre del 2016, 19:50:53 pm »
Vuelve a aparecer el problema con el reloj de la consola

Dec 12 16:39:20 raspberrypi weewx[2086]: engine: Clock error is -469.97 seconds (positive is fast)

jantoni

  • Visitante
Re:No me actualiza
« Respuesta #24 en: 13 de Diciembre del 2016, 19:56:14 pm »
Pues aquí está actualizando

Dec 12 16:40:43 raspberrypi weewx[2086]: genimages: Generated 11 images for SteelSeries in 1.51 seconds
Dec 12 16:50:21 raspberrypi weewx[2086]: cheetahgenerator: Generated 15 files for report StandardReport in 2.48 seconds
Dec 12 16:50:22 raspberrypi weewx[2086]: genimages: Generated 8 images for StandardReport in 1.30 seconds
Dec 12 16:50:22 raspberrypi weewx[2086]: cheetahgenerator: Generated 2 files for report SteelSeries in 0.19 seconds
Dec 12 16:50:24 raspberrypi weewx[2086]: genimages: Generated 11 images for SteelSeries in 2.27 seconds
Dec 12 17:00:20 raspberrypi weewx[2086]: cheetahgenerator: Generated 15 files for report StandardReport in 2.38 seconds

jantoni

  • Visitante
Re:No me actualiza
« Respuesta #25 en: 13 de Diciembre del 2016, 19:58:28 pm »
En definitiva, veo un problema de configuración de la hora de la consola, que se repite varias veces, comprueba la hora que tiene la consola.

Segundo tienes un problema de generación, porque Weewx está usando el tiempo de la consola, es decir, genera datos cada 10 minutos.

Y por último se ve un problema con el cable USB, esos errores LOOP que si no se vuelven a repetir, pues pasando. De lo contrario, piensa en comprar un par de ferritas para poner una a cada extremo del cable USB.....o comprar un cable USB decente.

Desconectado burgati

  • Full Member
  • ***
  • Mensajes: 196
    • Ver Perfil
  • Estación: "Burgos-Plaza san Agustín- ESCYL0900000009001D"
Re:No me actualiza
« Respuesta #26 en: 13 de Diciembre del 2016, 21:39:08 pm »
Gracias, a ver como voy arreglando....

En la consola tengo la hora UTC,(creo),  en esta época del año me marca una hora menos que la que tenemos en los relojes.

Esta semana hasta el lunes poco voy a poder investigar sobre el tema, gracias por la ayuda de nuevo.

Desconectado burgati

  • Full Member
  • ***
  • Mensajes: 196
    • Ver Perfil
  • Estación: "Burgos-Plaza san Agustín- ESCYL0900000009001D"
Re:No me actualiza
« Respuesta #27 en: 14 de Diciembre del 2016, 07:06:18 am »
Entonces.........debería cambiar cosas aquí:

segun by david nuño, en Flickr


O lo tengo que hacer en la consola......o en los dos sitios?

Desconectado burgati

  • Full Member
  • ***
  • Mensajes: 196
    • Ver Perfil
  • Estación: "Burgos-Plaza san Agustín- ESCYL0900000009001D"
Re:No me actualiza
« Respuesta #28 en: 14 de Diciembre del 2016, 14:33:02 pm »
Hola.....sigue sin actualizarme aunque en el archivo log si que manda paquetes le dejo adjunto......

Como no sé que hacer, puse un 600 en el archive interval en vez de un 900 que había por defecto y poco mas,,,,,no sé que es lo que tengo que hacer para resolver estos errores de reloj.....he probado a cambiar la hora en la consola pero se me vuelve a cambiar a horario utc.

Si a alguien le ha pasado lo mismo y podría orientarme diciendome que es lo que tengo que hacer exactamente ....gracias

Desconectado Wlarues

  • Full Member
  • ***
  • Mensajes: 174
  • Estudiante de Física en la Universidad de Zaragoza
    • Ver Perfil
    • El tiempo en Larués
  • Estación: ESARA2200000022761B
Re:No me actualiza
« Respuesta #29 en: 14 de Diciembre del 2016, 17:09:30 pm »
Hola burgati, no he tenido tiempo de mirar detenidamente el log pero creo que hace poco me pasó algo parecido:
http://forum.meteoclimatic.net/index.php/topic,885.0.html

El horario debe ser utc tanto en la raspi como en la consola. Una vez que esté solucionado eso, prueba a parar Weewx, cambiar la generacion a modo 'software' en Weewx.conf y volver a arrancar Weewx.

Si el programa arranca bien, debería generar las páginas con normalidad. Si es así, obsérvalo un rato y cuando estés seguro de que va bien, vuelve a parar Weewx, cambiar otra vez la generación a modo 'hardware' y vuelve a arrancar Weewx.

No estoy seguro de que sea el mismo problema que tuve yo, por desgracia no tengo mucho tiempo para profundizar en los errores que te salían en el log.

Si no te funciona avisa y a ver si te podemos ir ayudando  ;)

Saludos

Estación ESARA2200000022761B

Web Weewx: http://tiempo-larues.eu5.org