Autor Tema: Raspberry pi 3 + Weewx problemas  (Leído 29400 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.007
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #45 en: 16 de Octubre del 2016, 14:07:53 pm »
Instalando en este momento una Raspberri Pi 2 con el último Raspbian con Escritorio Pixel

De momento todo bien.....solo el tema de la fecha y la hora.

Ahora mismo actualizando la raspi.....todavía no ha llegado el script a la instalación de weewx
No respondo consultas por mensajería personal.

Davis Vantage Vue (sin datalogger) + Orange Pi PC + Weewx

Home Assistant + GW1000 + WH2650
Sensores: WH32P + WS65 + WH31 (3) + WH41 + WH32

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.007
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #46 en: 16 de Octubre del 2016, 14:28:52 pm »
Encontrado el problema

Hay un conflicto con la nueva versión de Raspbian.

Para solucionarlo, al menos a mi me ha funcionado, hay que borrar esta línea en el script:
Citar
ln -s /var/www/weewx /var/www/html/weewx


Es por lo queno me cuadraba el tema de los directorios.

Como ya tienes el sistema funcionando, borrando el enlace simbólico debería funcionar con la siguiente generación de ficheros:

Citar
sudo rm -f /var/www/html/weewx
sudo rm -f /var/www/weewx
En la siguiente generación deberían generarse los archivos.

« Última modificación: 16 de Octubre del 2016, 15:50:10 pm por jantoni »
No respondo consultas por mensajería personal.

Davis Vantage Vue (sin datalogger) + Orange Pi PC + Weewx

Home Assistant + GW1000 + WH2650
Sensores: WH32P + WS65 + WH31 (3) + WH41 + WH32

Desconectado The MeTTeacher

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
    • MeteoNoroeste de Murcia
  • Estación: ESMUR3000000030430A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #47 en: 17 de Octubre del 2016, 20:26:12 pm »
De momento todo bien.....solo el tema de la fecha y la hora.

Entiendo que tampoco te ha puesto la Raspi en hora, ¿no? De ser así, ¿como se soluciona este problema?

Estoy instalando Raspbian, si la hora no se pone sola, la pondré a mano e instalare el weewx haciendo lo que me comentas, sobre todo por curiosidad por ver si al final funciona y después corregiría lo de la hora... De no poderse arreglar a posterior, pues empezare de nuevo y ya me comentas si hay solución a lo de la hora previo a instalar weewx.

Si borras esa linea del script antes de su instalación, ¿ya no es necesario hacer el borrado del enlace simbólico? o por contra, ¿hay que hacer ambos pasos si o si?

Muchas gracias por tu inestimable ayuda.

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.007
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #48 en: 17 de Octubre del 2016, 20:35:41 pm »
Efectivamente, si borras esa línea, ya no hay que hacer el borrado del enlace posteriormente.

En el script publicado en mi web, ya está corregido.

En cuanto a la fecha, fue curioso.

Arranqué en modo desktop. Hora 4:03 UTC, cuando eran las 11:45 UTC o algo así.

Instalé ntpdate. Una chorrada por mi parte, porque ntpdate es solo para ejecutar desde la línea de comandos o desde el cron.

Ejecuto ntpdate y me dice que no se puede acceder a ninguno de los servidores....lógico porque no había programado ninguno.

Sabia que ntp estaba instalado (distinguir de ntpdate), por lo que no lo entendía.

Reinicié la raspi2. Cuando arrancó eran las 4:05 UTC y, a los pocos segundos cambió automáticamente.

No me gusta nada este comportamiento. No sé a que es debido, pero os recomiendo que activéis la opción de que la Raspi no termine de arrancar hasta que no tenga conexión a internet, por si las moscas.

Aunque no viene a cuento, me explico.

Aparte de Weewx, que no va a arrancar si no hay conexión a internet, hay que tener cuidado con iniciar una Raspi sin conexión a internet (aparte de weewx)

Todo el sistema de paquetes Debian utiliza una base de datos, indexada con hora, para saber que paquetes se han instalado, cuando, etc, etc.

Si la hora y fecha está mal, se puede corromper toda la base de datos. ¿resultado? no vamos a ser capaces de actualizar nada de nada....todo va a estar mal, nos dará errores cada vez que queramos instalar un paquete nuevo o una actualización,etc, etc.

Es el gran mal de las Raspi y máquinas similares, no disponer de reloj en tiempo real.
No respondo consultas por mensajería personal.

Davis Vantage Vue (sin datalogger) + Orange Pi PC + Weewx

Home Assistant + GW1000 + WH2650
Sensores: WH32P + WS65 + WH31 (3) + WH41 + WH32

Desconectado The MeTTeacher

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
    • MeteoNoroeste de Murcia
  • Estación: ESMUR3000000030430A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #49 en: 18 de Octubre del 2016, 18:47:27 pm »
Bueno, tras el primer intento me pasa algo similar... la hora estaba mal, y la fecha también. En mi caso espere y no se actualizaba, reinicie y tampoco.

Al final se la puse manual con sudo date --set "2016-10-18 18:41". Despues instale weewx con el script, y se instalo bien, pues me generaba las paginas.

Solo una cosa, al abrir el index de /var/www/weewx/html/ pues estaba la pagina con los datos de temperatura correctos pero la fecha y hora estaban mal...

Yo diría que el lio aquí es con el reloj, que hace que todo se vaya al traste...

No se si borrar todo, volver a meter raspbian y después intentar que la hora salga sola automática en vez de meterla a mano, pero claro, no se como se  haría eso...

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.007
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #50 en: 18 de Octubre del 2016, 19:10:09 pm »
Pues es que me extraña, porque esto no ha ocurrido nunca en la raspi.

Puede ser un problema de esa versión de Raspbian.

No he probado con la versión escritorio.

No es la primera vez que hay alguna cagada. De hecho todas las distribuciones de Linux, no solo de Raspbian, tienen alguna cosilla. Lo que ocurre es que esto es muy evidente.

Yo no hice más averiguaciones.

Comprueba que ntp está instalado y ejecutándose

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install ntp
sudo reboot

Para comprobar que ntp está funcionando

sudo ntpq -p

Si no te sale algo como esto

root@raspberrypi:~# sudo ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*ntp.redimadrid. 193.147.107.33   2 u  506 1024  377    4.787    0.040   0.310
root@raspberrypi:~#

Entonces ejecuta

sudo dpkg-reconfigure ntp

Reinicia y vuelve a probar el sudo ntpq -p

Saludos.
No respondo consultas por mensajería personal.

Davis Vantage Vue (sin datalogger) + Orange Pi PC + Weewx

Home Assistant + GW1000 + WH2650
Sensores: WH32P + WS65 + WH31 (3) + WH41 + WH32

Desconectado Xavi-EA5ZF

  • Full Member
  • ***
  • Mensajes: 212
  • Ham Radio Operator EA5ZF
    • Ver Perfil
    • MeteoLaVall
  • Estación: ESPVA1200000012600A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #51 en: 18 de Octubre del 2016, 20:19:04 pm »
Citar
No me gusta nada este comportamiento. No sé a que es debido, pero os recomiendo que activéis la opción de que la Raspi no termine de arrancar hasta que no tenga conexión a internet, por si las moscas.

Cual es esa opción y donde está para modificarla?

Te cuento, con la rapi ya me ha pasado alguna vez alguna cosa rara con el reloj y por eso metí el Mele, cuando hay un reinicio forzoso (tengo un SAI) arranca antes que el router (le cuesta un momento iniciar la ADSL) y el Mele arranca con fecha 1 de enero de 2010. Si arranca weewx me mete uno o varios registros en la BBDD, pero eso no es lo peor, lo peor es que manda la hora a la DAVIS y me toca borrar el dataloger entero o sea que pierdo todo entre la hora de reinicio y cuando en persona lo soluciono.
No es normal que pase lo del reinicio, pero esta semana o hay un problema del pobre y viejo alimentador del Mele o el SAI tiene un problema y ha sucedido 2 veces. Y me ha podrido la BBDD del weewx perdiento 2 horas una vez y 4 la otra.
Xavi
Como me pasaba eso cambié al MELE y esta semana llevo dos reinicios y este mete la hora del 1 de enero de 2010

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.007
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #52 en: 18 de Octubre del 2016, 21:43:47 pm »
Xavi, esa opción la he visto en los Raspbian con Escritorio.

Tengo por aquí unas fotos.....pero el límite de 192KB me tiene atado
No respondo consultas por mensajería personal.

Davis Vantage Vue (sin datalogger) + Orange Pi PC + Weewx

Home Assistant + GW1000 + WH2650
Sensores: WH32P + WS65 + WH31 (3) + WH41 + WH32

Desconectado The MeTTeacher

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
    • MeteoNoroeste de Murcia
  • Estación: ESMUR3000000030430A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #53 en: 19 de Octubre del 2016, 00:31:26 am »
Tras hacer tu recomendación con lo de:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install ntp
sudo reboot
Ahora parece que la hora se actualiza sola, al menos lo he reiniciado desconectando el cable incluso y la hora después ha aparecido.

He instalado también el script del weewx y genera las paginas, pero del dia 15 de este mes, he mirado su log y ha ido descargando los datos del dataloger cada 5 minutos hasta el pasado sábado 15. Imagino que algo debe estar mal para que no descargue el resto y tampoco los datos actuales.

Mañana otro ratillo pero estoy esperanzado, parece que la cosa se va encaminando.

Un saludo y muchas gracias por la gran ayuda que me dais.

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.007
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #54 en: 19 de Octubre del 2016, 09:41:09 am »
Si tienes abierta la página web, dinos la dirección.

Así podemos ir viendo tus progresos.

Saludos.
No respondo consultas por mensajería personal.

Davis Vantage Vue (sin datalogger) + Orange Pi PC + Weewx

Home Assistant + GW1000 + WH2650
Sensores: WH32P + WS65 + WH31 (3) + WH41 + WH32

Desconectado The MeTTeacher

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
    • MeteoNoroeste de Murcia
  • Estación: ESMUR3000000030430A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #55 en: 26 de Octubre del 2016, 20:49:59 pm »
Al final me creo las paginas en la carpeta de weewx, pero con los datos de hace una semana, es decir, no actualiza con los datos actuales de la consola. Tampoco sube las paginas al servidor.

Instalando con el script automático me salen varias cosas que antes no salían, y no se si le habré dado a la opción correcta.

La siguiente imagen es de unos de los mensajes que me salían. (Imagino que es debido al cambio de versión del Raspbian).



Ademas, aquí me hace una pregunta que yo le dije que si, pero no se si era la opción correcta o no...


Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.007
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #56 en: 26 de Octubre del 2016, 21:54:37 pm »
Esa pregunta no afecta para nada, es para la configuración del gestor de escritorio.

Para ver que ocurre con tu estación deberás acudir al log de weewx donde nos dirá cual es el problema.

Saludos.
No respondo consultas por mensajería personal.

Davis Vantage Vue (sin datalogger) + Orange Pi PC + Weewx

Home Assistant + GW1000 + WH2650
Sensores: WH32P + WS65 + WH31 (3) + WH41 + WH32

Desconectado The MeTTeacher

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
    • MeteoNoroeste de Murcia
  • Estación: ESMUR3000000030430A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #57 en: 01 de Noviembre del 2016, 17:46:49 pm »
Estoy subiendo datos a AWEKAS
http://www.awekas.at/de/instrument.php?id=2868

También a Wunderground
https://www.wunderground.com/personal-weather-station/dashboard?ID=IMURCIAC3

Pero no consigo que funcione el ftp. He estado probando cosas pero nada.

¿Alguien me puede poner como tiene puesto ese apartado en su weewx? Todo esta correcto, lo que no se es la parte del servidor, que tengo puesto lo mismo que con Filezilla por ejemplo funciona, pero aquí nada.

Mi servidor es de 1&1, no se si hay que hacer algo especial por ello.

Desconectado jantoni

  • Investigación
  • Hero Member
  • ******
  • Mensajes: 4.007
    • Ver Perfil
  • Estación: ESMAD2800000028522A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #58 en: 01 de Noviembre del 2016, 20:02:49 pm »
Para mandar desde la Raspberry Pi a un Mele A2000 que hace de servidor Web
Citar
    [[FTP]]
        # FTP'ing the results to a webserver is treated as just another report,
        # albeit one with an unusual report generator!
        skin = Ftp

        # If you wish to use FTP, uncomment and fill out the next four lines:
        user = xxxxxxxxxx
        password = xxxxxxxxxxx
        server = 192.168.0.78
        path = /var/www/weewx

        # Set to True for a secure FTP (SFTP) connection. Not all servers
        # support this:
        secure_ftp = False

        # If you wish to upload files from something other than what HTML_ROOT
        # is set to above, then reset it here:
        #HTML_ROOT = /var/www/weewx

        # Most FTP servers use port 21, but if yours is different, you can
        # change it here
        port = 21

        # Set to 1 to use passive mode, zero for active mode:
        passive = 1

No respondo consultas por mensajería personal.

Davis Vantage Vue (sin datalogger) + Orange Pi PC + Weewx

Home Assistant + GW1000 + WH2650
Sensores: WH32P + WS65 + WH31 (3) + WH41 + WH32

Desconectado The MeTTeacher

  • Newbie
  • *
  • Mensajes: 26
    • Ver Perfil
    • MeteoNoroeste de Murcia
  • Estación: ESMUR3000000030430A
Re:Raspberry pi 3 + Weewx problemas
« Respuesta #59 en: 02 de Noviembre del 2016, 00:16:16 am »
En 1and1 me ponía que el puerto era el 22, sin embargo, decidí poner el 21 y no poner que fuese un servidor seguro, pese a que según la compañía si lo era.

Haciendo eso me di cuenta que subió 6 gráficas y la pagina de month, tras eso y en el transcurso de una hora ha ido poco a poco aumentando el numero de cosas que sube a mi servidor y ahora sube todas las plantillas. No se si se os ocurre el porque de subir primero solo una pagina html y 6 fotos y poco a poco ir aumentando, pero tras mas de mes y medio me parece medio magia... :-X

http://www.meteonoroeste.es/weewx/index.html

En teoría la plantilla de meteoclimatic la esta subiendo, sin embargo, al abrirla aparecía con los campos de este estilo:
PD=%date% %time% *TMP=%temp% *WND=%10minavspeedinkmh% *AZI=%avdir10minute% *BAR=%baro% *HUM=%hum%
No he metido la dirección en meteoclimatic porque imagino que algo esta mal al no aparecer los datos. Mañana intentare ver si eso se soluciona...